Opened 7 years ago

Closed 7 years ago

#9309 closed Bug (fixed)

Incorrect delete key behavior before list item

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: IBM Cc: Damian, Teresa Monahan

Description

  1. Load the following into editor

 <p>&nbsp;</p>
    <ol>
    	<li>
    		B</li>
    	<li>
    		C</li>
    </ol>
  1. Place cursor at end of first empty paragraph;

  1. Press DELETE.

Expected Result: Empty Paragraph gets deleted

Actual Result: We are getting Javascript error & error is object doesn't support this property or method, when we close error dialog, list items no longer appear as a list (even though li is still displayed on the elements path bar).

Change History (3)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0
Status: newconfirmed
Summary: IE: Javascript error when we press delete before list itemIncorrect delete key behavior before list item

There are two issues:

  1. Error thrown on del/backspace: #9333.
  2. Incorrect (inconsistent) delete key behavior before list item. I've made quick test in FF, IE8 and Chrome and all of them behaved differently.

First issue is already reported, so this ticket will refer to the second one.

comment:2 Changed 7 years ago by Garry Yao

Status: confirmedpending

WFM on latest master, seems to be fixed by recent commits?

comment:3 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy