Opened 12 years ago

Closed 12 years ago

#933 closed Bug (fixed)

FCKDomRange.MoveToSelection() crashes in Internet Explorer when editor frame has never been selected

Reported by: Martin Kou Owned by: Martin Kou
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description

Reproduction Procedure:

  1. Open one of the _samples/html/sample01.html sample in Internet Explorer 6. Do not click on the editor widget.
  2. Type in the address bar, the following:
    javascript: void(window.r = new frames[0].FCKDomRange(frames[0].frames[0]));
    javascript: void(window.r.MoveToSelection());
    
  3. A JavaScript error is generated.

Why is this important?
The same error does not happen in Firefox or Opera. This error makes it necessary to write an extra try... catch... statement in code that deals with selection by DOM Ranges. Moreover, when the MoveToSelection() operation crashes, it might insert trash HTML code to parent document containing the FCKeditor widget, which is nasty.

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

This bug was discovered while I was working on #802, it seems to be simple to solve, and it would be required to make FCKeditor's replace operation behave more like MS Word's. So I'll fix this before fixing #802.

comment:2 Changed 12 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [407].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy