Opened 7 years ago

Closed 6 years ago

#9334 closed Bug (fixed)

IE10 cannot aplly toLowerCase() to undefined. CKEditor blocked.

Reported by: Andrei Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: IE Cc:

Description

IE10 cannot aplly toLowerCase() to undefined. CKEditor blocked.

Attachments (1)

magiclineInlineMouseout.png (21.1 KB) - added by Olek Nowodziński 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Jakub Ś

Please provide more detailed scenario for this bug.

comment:2 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Function toLowerCase()works on IE10. Object on which you try to invoke it is undefined but based on your short description I can't whether it was your mistake or editor bug, I actually can’t say anything.

I'm closing this issue as invalid. Please provide detailed description saying what is wrong and how to reproduce it and I will reopen this issue.

comment:3 Changed 6 years ago by Garry Yao

Milestone: CKEditor 4.0
Resolution: invalid
Status: closedreopened
  1. Load replacebyclass sample
  2. Click into the editable region;
  3. Mouse over the the v-scroll bar
  • Actual: JavaScript error occurs

comment:4 Changed 6 years ago by Garry Yao

Keywords: IE added; IE10 removed
Owner: set to Garry Yao
Status: reopenedreview
Version: 4.0 (GitHub - master)

It's just the magicline plugin that get affected, opened t/9334 on dev for review.

comment:5 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_failed

t/9334@cksource modifies the logic of the magicline and breaks the mouseout hiding feature. For example:

  1. Go to http://ckeditor4.t/ckeditor/samples/magicline.html
  2. Scroll down the first sample.
  3. Put the mouse pointer over the last 3 paragraphs and move it down towards the elementspath.
  4. Magicline appears when near the bottom of the editable.
  5. Move the pointer slowly and gently down so it eventually leaves the editable.
  6. Magicline is still here.

Also the following code doesn't make much sense for me:

else {
	if ( ... ) {
		...
	}
}

Please, provide some extra info about the bug (I don't have IE10) so we could fix it together.

comment:6 Changed 6 years ago by Garry Yao

Status: review_failedreview

Ok, I noticed it breaks it somehow, while we need to understand that the feature itself is not completed - moving to the outside from the right side in LTR (confirmed in at least IE9 doesn't detach the magicline).

Anyway, I believe it's much simpler to achieve the same thing with the mouse out event on iframe, pushed a commit for that.

The problem on IE10, is that it's relatedTarget/srcElement returns an empty object.

comment:7 in reply to:  6 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_failed

Replying to garry.yao:

Ok, I noticed it breaks it somehow, while we need to understand that the feature itself is not completed - moving to the outside from the right side in LTR (confirmed in at least IE9 doesn't detach the magicline).

Anyway, I believe it's much simpler to achieve the same thing with the mouse out event on iframe, pushed a commit for that.

The problem on IE10, is that it's relatedTarget/srcElement returns an empty object.

Mouseout support in magicline isn't as simple as it seems to be. This implementation breaks inline editing. Simply run inlineall sample, reveal the line, keep the mouse on the line and move it towards the edge so it eventually leaves editable area. Line is still visible (screenshot).

Changed 6 years ago by Olek Nowodziński

Attachment: magiclineInlineMouseout.png added

comment:8 Changed 6 years ago by Garry Yao

Status: review_failedreview

Sorry, I didn't mean to change any code lines regard inline, so I've reverted that little mistake from the patch.

comment:9 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

R+, seems to be working ;) Since I don't have IE10, I trust you and I assume that problem is solved.

Anyway, I discovered another issue with mouseout on master so I'll create a ticket for it.

comment:10 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy