Opened 7 years ago

Closed 7 years ago

#9339 closed Bug (invalid)

bold behaves oddly for collapsed range

Reported by: yiminghe Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version:
Keywords: Cc:

Description

the first problem:

steps:

  1. click 'bold' button at the end of line:

http://img01.taobaocdn.com/tps/i1/T1SEDNXl8cXXblsyDO-158-131.png_110x110.jpg

http://img01.taobaocdn.com/tps/i1/T1F1YNXi0gXXb5cmz8-169-134.png_110x110.jpg

  1. move cursor left by pressing left arrow of keyboard

http://img03.taobaocdn.com/tps/i3/T1Nd2OXipXXXa2pt_j-142-109.png_110x110.jpg

  1. move cursor right by pressing right arrow of keyboard

expected:

can return to previous bold status.

actual:

no matter how many right arrow key are pressed, i can not return to previous bold status.

http://img02.taobaocdn.com/tps/i2/T11SHLXcxmXXct30b.-173-149.png_110x110.jpg

the second problem:

steps:

  1. click 'bold' button at the end of line:

http://img01.taobaocdn.com/tps/i1/T1SEDNXl8cXXblsyDO-158-131.png_110x110.jpg

http://img01.taobaocdn.com/tps/i1/T1F1YNXi0gXXb5cmz8-169-134.png_110x110.jpg

  1. click 'bold' button again

expected:

current dom tree does not contains 'strong' element.

actual:

strong element still exists

http://img04.taobaocdn.com/tps/i4/T1yKzJXoppXXXE6CIg-388-203.png_110x110.jpg

attachment is a patch for problem 2.

Attachments (1)

remove_styles_9339.patch (1.3 KB) - added by yiminghe 7 years ago.
for problem 2

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by yiminghe

Attachment: remove_styles_9339.patch added

for problem 2

comment:1 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 3.6.5 (SVN - trunk)

Both 1 and 2 are by design.

Ad 2. Although you can see strong element when examining WYSIWYG area with Firebug or similar tool please note that you don't see this element in elements path. Furthermore you will not see that element when switching to source nor you will see it when using getData() on editor.
This can be treated like some internal attribute that CKEditor adds in WYSIWYG mode and you should not be interested in it as it doesn’t have any impact on final result.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy