Opened 7 years ago

Closed 6 years ago

#9371 closed Bug (expired)

Inline editing: with JAWS virtual Cursor we can't navigate whole sample page using arrow keys

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. with JAWS on, Open Massive inline editing sample
  1. Navigate the sample page in Virtual Cursor mode( using arrow keys)

Issue: After reaching 3rd div, focus goes to editor body, and we can't come out of editor body using arrow keys

Only way to go to next div is using tab to exit editor body

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending
Version: 4.04.0 Beta

Virtual cursor can be activated with the Num Pad Minus key on Desktop Computer or Alt + P on Laptop. The Num Pad Minus key is located on the upper right corner of the numeric keypad.


Using virtual cursor it is only possible to enter div with id headerRight but this looks like JAWS issue not editor issue.

I have tried this sample without editor logic and it has worked the same. It seems that despite as Freedom Scientific has written about support for contenteditable elements (http://www.freedomscientific.com/fs_products/software_jaws401newfea.asp) there are still problems with virtual cursor and e.g div with contneteditable="true".

Similar problems occur with e.g. from elements but at least it is possible to leave them by e.g pressing down arrow two times quickly.

@satya are you getting this problem only in CKEditor or like me in divs with contenteditable="true"

comment:2 Changed 6 years ago by Jakub Ś

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy