Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9390 closed Bug (invalid)

"Remove Link" button stays disabled when links are selected

Reported by: dave Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Frederico Caldeira Knabben)

Steps to reproduce (any browser):

  1. Navigate to demo page: http://ckeditor.com/demo
  2. Click inside the editor to give it focus
  3. Select all the text by typing CTRL-A

Expected behavior is RemoveLink button becomes enabled. This was working fine in previous versions.

Change History (2)

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:2 Changed 6 years ago by Jakub Ś

Keywords: remove link removed
Resolution: invalid
Status: newclosed
Version: 3.6.4

This was working fine in previous versions.

It has never worked like you have described it.

The only time when unlink button get enabled and it is possible to unlink all links in text after pressing CRTL+A is when selection starts with link (link is at the beginning of selected text). But this is not a bug but rather accidental extra feature.
The main reason for not analysing whole text is performance. Editor can't search whole selection for links, images, form elements etc. because it would simply take too long.
So instead, editor is analysing only boundary of selection (beginning in this case) and if there is a link unlink button gets enabled.

Last edited 6 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy