Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9431 closed Bug (invalid)

Wrong behaviour for Enter with multiple instances.

Reported by: Francisco Owned by:
Priority: Normal Milestone:
Component: UI : Enter Key Version: 3.6.4
Keywords: Cc:

Description

If there is more than 1 instance of CKeditor and I press enter in the second or consecutive ones, the whole page moves down. It doesn't happen when I only have one, but it happens both with the _samples example (second one) and when I use the code for my pages. Couldn't test it in the Demo from the page since there's only one instance. It's a fresh install with no plugins.

Steps to reproduce:

  1. Go to the /ckeditor/_samples/replacebycode.html , but don't get in the bottom of the page (so you can see the effect).
  2. Write some text.
  3. Press Enter.
  4. The line break get's printed in the textarea and the whole page moves down a lot. I'd say same thing as 'Page Down'.

Google Chrome Version 22.0.1229.79 with AdBlock Plus and Do Not Track Plus extensions in Ubuntu.

The page on my site to check the bug: http://newfutureuniversity.org/ckeditor/_samples/replacebycode.html

Change History (5)

comment:1 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I have checked replacebycode.html sample and this issue does not occur there.

I have then checked your page and IMO this scrolling happens because you have invalid page structure. The main error is having nested html tags. I don't remember this being valid in HTML5 or any HTML spec ;)

Please see link from validator - http://html5.validator.nu/?doc=http%3A%2F%2Fnewfutureuniversity.org%2Fckeditor%2F_samples%2Freplacebycode.html
It should give you an idea what should be fixed.

comment:2 in reply to:  1 Changed 7 years ago by Francisco

I should have modify the page itself (it auto-loads a lot of code) for the bug, I apologize for that.

Here you can see a page that validates perfectly with HTML5, not even a warning, but still suffers the same problem as explained in the first post: http://newfutureuniversity.org/subject/new

Can you point somewhere that I can test if it's my browser's problem or a general bug please?

Replying to j.swiderski:

I have checked replacebycode.html sample and this issue does not occur there.

I have then checked your page and IMO this scrolling happens because you have invalid page structure. The main error is having nested html tags. I don't remember this being valid in HTML5 or any HTML spec ;)

Please see link from validator - http://html5.validator.nu/?doc=http%3A%2F%2Fnewfutureuniversity.org%2Fckeditor%2F_samples%2Freplacebycode.html
It should give you an idea what should be fixed.

Last edited 6 years ago by Francisco (previous) (diff)

comment:3 Changed 6 years ago by Jakub Ś

Hi @Frank91, sorry for late response.

Your ticket is in fact a duplicate of #9136.

You problem is CSS rule set for body - height:100%. Please change it to height:auto and problem will be gone.

comment:4 Changed 6 years ago by Francisco

No worries,

Oh I didn't find that before. If I change it to auto, the bug 'gets fixed' but my page breaks at some points (the sticky footer stops being sticky). Is there any other workaround? I've seen on the other post that older versions of CKeditor didn't have this problem.

Anyway, thank you for taking the time to answer.

comment:5 Changed 6 years ago by Jakub Ś

This is a little bit out of scope of bug reporting but here goes:

  1. In sample.css you have rule set for body padding: 10px 30px;
  2. you should change it to padding: 10px 30px 0;
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy