Opened 7 years ago

Last modified 7 years ago

#9433 confirmed Bug

[FF] "Browse Server" popup appears behind browser window

Reported by: Sebastian Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.0
Keywords: Firefox Cc:

Description

In Firefox 15.0.1, the image "Browse server" popup appears behind the main browser window. When you remove the popup and try again the popup appears in front, as it should.

Change History (8)

comment:1 Changed 7 years ago by Jakub Ś

Status: newpending

I was not able to reproduce this. Could you please provide more information?

What are the exact steps to reproduce the problem?

comment:2 Changed 7 years ago by Sebastian

Steps to reproduce:

  1. Clear FF cache
  2. Go to demo: http://ckeditor.com/demo
  3. Press Image button
  4. Press Browse Server button

The Browse Server window will appear for a split second then go behind the main browser window.

comment:3 Changed 7 years ago by Wiktor Walc

@j.swiderski - this bug seems to be tricky. Are you able to reproduce it with the following TC?

  • close all tabs in Firefox and restart the browser
  • open in the first tab http://ckeditor.com/demo (make sure that you did not open any other page before that)
  • open Link dialog and click "Browse Server"

The tricky thing: the demo page must be opened as the first page in the first tab. At least this is the only scenario where it is happening to me, @Sebastian do you ave the same results?

comment:4 Changed 7 years ago by Sebastian

I set the demo page as my home page. I get the bug whether the page is in the first tab, middle or last. It sometimes doesn't popunder. Can't figure out why. Tried every option imaginable.

Last edited 7 years ago by Sebastian (previous) (diff)

comment:5 Changed 7 years ago by Sebastian

Seems to be ok now with v4.0.1 in FF18, at least in Drupal and Demo page. And since there was no patch for it on our end, it looks like it was a Firefox bug.

comment:6 Changed 7 years ago by Jakub Ś

I was not able to reproduce it either.

I have tried on 32 and 64 bit Windows. I have tried opening CKEditor (demo and local) as first page in first tab or as start page and none of this resulted in error.

I'm not able to reproduce this (I wasn't able before so my opinion isn't the most important here :) )

comment:7 Changed 7 years ago by Wiktor Walc

Strange, but wfm. Must have been fixed in FF.

comment:8 Changed 7 years ago by Jakub Ś

Status: pendingconfirmed
Version: 3.0

Ok, I was able to reproduce this problem in Firefox 18 and only in Win7 (Win8 and XP seem to work fine here)

  1. Close all tabs but one in FF and clear browsers cache.
  2. Set FF to open with empty page.
  3. Close and Open browser.
  4. Insert URL that leads to CKFinders's /ckeditor.html sample.
  5. Click image toolbar button and Browse Server.

Result: Window will show in from for a moment and that will hide behind main window.

With the above TC you should be able to reproduce this in both CKEditor 3.x and 4.x (v4).

NOTE: I have first managed to reproduce this by joining CKFinder with CKEditor v4 as suggested by one of users.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy