Opened 7 years ago

Closed 7 years ago

#9465 closed Bug (fixed)

Misplaced panels when editor is being maximized

Reported by: Olek Nowodziński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0
Component: UI : Floating Panel Version: 4.0
Keywords: Cc:

Description

  1. Open http://ckeditor4.t/ckeditor/samples/replacebycode.html
  2. Open a panel (for example a text colour panel).
  3. Click maximize.
  4. See things flying here and there.

PS. There's already a maximize event implemented which can be used to solve this problem.

Attachments (1)

misplacedPanelOnMaximize.png (118.1 KB) - added by Olek Nowodziński 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Olek Nowodziński

comment:1 Changed 7 years ago by Piotrek Koszuliński

Another TC:

  • Maximize editor.
  • Right-click to open context menu.

It's invisible, but it's opened, because I was able to navigate through it with keyboard.

comment:2 Changed 7 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:3 Changed 7 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:4 Changed 7 years ago by Piotrek Koszuliński

Status: assignedreview

TC1 (misplaced panels) isn't a regression sinve v3, but after introducing maximize event it was trivial to fix.

TC2 (invisible context menu) was an issue caused by incorrect z-index.

I pushed t/9465.

comment:5 Changed 7 years ago by Garry Yao

Status: reviewreview_failed

It's not a good practise to have one plugin aware of other plugin's specific event (maximize), editor#resize event should be used instead, as a core event to coordinate edito resizing.

The baseFloatZIndex related fix looks good though.

comment:6 Changed 7 years ago by Piotrek Koszuliński

Status: review_failedreview

Ok - I pushed version with 'resize'.

comment:7 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

comment:8 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy