Opened 6 years ago

Closed 6 years ago

#9487 closed Bug (fixed)

Paragraph format combo loses ON state

Reported by: Olek Nowodziński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

Unlike other combo boxes, paragraph format (format plugin) is unable to hold its cke_combo_on class (ON state) when opened. It seems that this problem exists in the editor for a long time as this class has never (recently?) been used in kama.

To reproduce, place trace() in richcombo plugin and see that setState is called twice when the combo is being opened.

The reason for this might be the selectionChange callback in format plugin as deleting this single line solves the problem.

The problem is easy to observe with latest t/9423@cksource branch as Moono skin (unlike Kama) defines on state for combos.

Change History (4)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: newassigned

comment:2 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Format combo listens on selectionChange event to update its state. However, this event is also thrown on combo open, so it overwrites the ON state. I pushed t/9487 with simple check stopping execution when combo is opened.

comment:3 Changed 6 years ago by Garry Yao

Status: reviewreview_passed

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy