Opened 7 years ago

Closed 5 years ago

#9493 closed Bug (duplicate)

Opera: Incorrect options shown in Context menu

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. Open Ajax Sample and click on Create Editor button.
  1. Keep cursor at end of editor body & right click the mouse to open Context menu.

Issue 1: Browser Context menu gets opened instead of CK Editor context menu.

  1. Now click near start of editor body & right click the mouse to open context menu.

Issue 2: CK Editor context menu opens, but it shows Delete Table & Table Properties options in Context menu even though there was no Table inserted in editor body.

Attachments (2)

native.png (33.0 KB) - added by Jakub Ś 7 years ago.
table.png (20.6 KB) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Jakub Ś

Attachment: native.png added

Changed 7 years ago by Jakub Ś

Attachment: table.png added

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

Table menu is hard to reproduce at first.

Cursor blinks in first line. To reproduce table menu I had to right-click below this first line and then at the same height as first line, about 1cm behind blinking cursor.

If you right-clicking in the first line - context menu will never show up; perhaps another bug or extension to this one.

This issue can only be reproduced in v4 of the editor

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I wasn't able to reproduce issue 2 in latest Opera 18.

Issue 1 is a duplicate of #10169.

I'm closing this ticket in favour of #10169 because the later one focuses on native browser menu only.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy