Opened 6 years ago

Closed 5 years ago

#9505 closed Bug (fixed)

[FF] Editor placeholder option not available in context menu after first right-click on placeholder

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: UI : Context Menu Version: 3.5
Keywords: Firefox Cc:

Description

  1. Open placeholder sample.
  2. Click on text.
  3. Right click on placeholder.
  4. There's no "edit placeholder" option in context menu - only "paste" is available.
  5. Right click again - "edit placeholder" appears.

Expected: "edit placeholder" should be available on first time.

Reproducible in v3 and v4.

Change History (4)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Component: GeneralUI : Context Menu
Keywords: placeholder added

comment:2 Changed 6 years ago by Jakub Ś

Keywords: Firefox added; placeholder removed
Status: newconfirmed
Version: 3.6.53.5

Reproducible from CKEditor 3.5 in Firefox.

comment:3 Changed 6 years ago by Jakub Ś

Whether edit placeholder option is available in context menu depends whether you left-click inside content area first or not.

  1. Click outside of contentarea and then right-click on place holder - you get the edit menu 2. Left click in content are somewhere and the right click on placeholder - you get only paste.

It has been working that way from CKE 3.5.
NOTE: From CKE 3.5 till CKE 3.6.3 initial right-click on menu caused menu to show up for only a second. This was fixed in CKE 3.6.4.

comment:4 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Not applicable any more, because we removed the context menu option. Also - it'll work if we'll add it, since widgets handle context menu correctly.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy