Opened 6 years ago

Closed 6 years ago

#9512 closed Bug (fixed)

Extra files in skins/moono folder

Reported by: Wiktor Walc Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0
Component: General Version:
Keywords: Cc: a.nowodzinski@…

Description

Did not check but I guess they're not used anywhere per se:

  • icons.svg
  • icons_export_16.png

total size: 250kB.

I believe something must be done with them in order to reduce the size of release package.

Change History (11)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Cc: a.nowodzinski@… added

Olek (cced) will know, but AFAIK they are completely needless in release package.

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

I agree that icons_export_16.png can be deleted.

As for icons.svg, it is the "source" version of the icons, so it is ok to have it on dev. In the other hand, we need to have a way to tell the builder to ignore it.

comment:3 Changed 6 years ago by Wiktor Walc

One of the possible solutions would be to introduce manifest.js. It could be used to remove various files that are not needed in the release package.

var MANIFEST = {
	ignore: [
		'icons.svg'
	]
}

If we are going to introduce this, we could consider adding the dependency information to the manifest file as well. Right now I'm using regex to parse the requires: statement in plugin.js. It works quite well at this moment, but is a bit ugly. On the other side, the dependency information would be duplicated in two places (the manifest file & plugin.js), so have no idea which option is better.

comment:4 Changed 6 years ago by Wiktor Walc

After a bit more of thinking I changed my mind, I think the right place for all development stuff is... the "dev" subfolder of a skin/plugin. This subfolder could be ignored by builder, just like the "root" /dev folder.

So, if we want to keep some "source version" of a file with all icons, let's put it into dev/icons.svg, even along with a custom script that can cut the file into separate icons.

If we want to keep some "development" samples that are not to be included in the release (like plugins/magicline/samples/sample.html), let's put them into the "dev" folder to avoid confusion, and so on.

What do you think?

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Status: newconfirmed

Good idea... let's proceed with the "dev" folder.

comment:6 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:7 Changed 6 years ago by Piotrek Koszuliński

Owner: Piotrek Koszuliński deleted
Status: assignedconfirmed

Pushed t/9512.

I've cleaned up samples and source files by moving them to dev folders or removing ones that are doubled (which are in global samples folder and inside plugins).

I also thought that it'll nice to have builder flag --leave-dev-folders/dirs, because e.g. sometimes I need clipboard sample in release version, as it helps to verify if everything works fine.

And one more thought regarding samples builder - please remember that we need them also in dev mode, so they should work after moving them to plugins folders.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedreview

Samples builder is targeted by #9564, so this ticket goes on review.

comment:9 Changed 6 years ago by Wiktor Walc

@Reinmar "dev" is already ignored thanks to the "ignore" entry in build-config.js. So in order to keep the dev folders in release version, simply correct the "ignore" array in build-config.js.

comment:10 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:11 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy