Opened 7 years ago

Closed 6 years ago

#9525 closed Bug (wontfix)

[Opera] Tab key based navigation - first tab always jumps to editor with tabIndex=1

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: Cc: Hallvord R. M. Steen (Opera Software)

Description

  1. Open tabindex sample.
  2. Focus editor with tabIndex 1, 2 or 3.
  3. Press tab.
  • Expected: editor with tabIndex 2, 3 or 4 focused.
  • Actual: Focus is set on editor with tIndex = 1.

Change History (6)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: newassigned

comment:2 Changed 7 years ago by Piotrek Koszuliński

Looks like Opera's issue - focus isn't fired on editable although it's moved there. I have to prepare simplified TC to verify this.

comment:3 Changed 7 years ago by Piotrek Koszuliński

Cc: Hallvord R. M. Steen (Opera Software) added

comment:4 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0
Version: 4.0 (GitHub - master)

I confirmed this issue also on v3.

comment:5 Changed 7 years ago by Jakub Ś

Version: 3.2

I have been able to reproduce this issue from CKEditor 3.2.

Ironically this is the version when editor.tabIndex started working (before this version editor.tabIndex has been giving undefined).

comment:6 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: assignedclosed

Not reproducible in Opera 15+.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy