Opened 7 years ago

Closed 7 years ago

#9562 closed Bug (wontfix)

blur and focus fired when opening/closing dialogs

Reported by: Jeff Fournier Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: Cc:

Description

The blur/focus events are fired every time the text area is entered/leaved. This cause the events to be fired when you open/close a dialog.

This makes it impossible to detect a real blur/focus from the editor because the event is fired too often.

Change History (3)

comment:1 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

In CKEditor 3.x the "focus"/"blur" event refers to the activte state of the editing area (wsiywg frame). It's by design and can't be changed.
It was changed however in CKEditor 4.x.

This is a won't fix in v3 but works as expected in v4.

comment:2 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: closedreopened

comment:3 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy