Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9585 closed Task (invalid)

Builder generates an "icons.png" file under plugins

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Normal Milestone:
Component: Project : CKBuilder Version: 4.0
Keywords: Cc:

Description

Using the builder instead of the dev version (also visible in the nightly zip), there's an icons.png file generated on the /plugins/ folder.

It uses the kama icons, but to make it even funnier, it's not the same icons.png found under the kama skin.

Currently it seems that the editor doesn't load it, so it seems like a leftover from the build process.

Change History (6)

comment:1 Changed 7 years ago by Wiktor Walc

This is by design. Skins are not required to provide any icons. All of them come from plugins by default.

It means, that there must be a way to display properly the toolbar with a skin downloaded separately, that was not available in the build process, and that does not provide icons for all buttons.

Suppose we have a toolbar [A B C D]. Skin "foobar" provides icons only for C, D. Icons for A B will come from plugins/icons.png strip in such scenario.

If it's still confusing, let me know.

comment:2 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

@wwalc, thanks to your graphic example ;) is clear enough to close this issue.

comment:3 Changed 6 years ago by Hank

I'm having a problem with this default icons.png file in the /plugins directory.

It appears to be overriding the icons supplied in the "kama" skin. I have just installed ckeditor 4.0.1 and the kama skin found on the add-ons page, but no matter what I do (set config.skin='kama' in config.js file, etc) the icons in the /plugins/icons.png file display/override all icons in the skin specified. Other settings in config.js take affect, but not config.skin.

Reviewing the apache logs, the /plugins/icons.png file is called every time, and no icons from the kama skin are requested.

comment:4 Changed 6 years ago by Wiktor Walc

@hanklloydright - that's in fact another problem, which I fixed just a few minutes ago. Thank you for detailed explanation of the issue.

The version of the skin offered for download was in fact a "source" version which was not recognized by CKEditor. When adding new releases of our skins in the addons repository, the skin should be built first and offered as "release" version, with all icons located in a single strip.

Please re-download the Kama skin and try again.

comment:5 Changed 6 years ago by Hank

Thank you, that worked perfectly.

I'm relatively new to ckeditor (that is, customizing and configuring it differently that "out of the box"). I spent about 5 hours yesterday trying to get this working since I just assumed I was doing something wrong. It wasn't until I started testing changing skins in an install of 3.6.2 where I could change them very simply did I then realize that the 4.0.1 version might be buggy. But I really can't complain since it's free (and very awesome) software. :)

Quick noob question: Is the "config.js" file automatically loaded by ckeditor.js, or do I have to load it in addition to ckeditor.js in order for it to be recognized? In 3.6.2, it appears to be read automatically, but in 4.0.1, the settings in config.js aren't recognized unless I load it along with (after) ckeditor.js.

comment:6 Changed 6 years ago by Jakub Ś

File ckeditor/config.js is loaded automatically. Sometimes (depending on browser) cache refresh (usually CTRL+F5 is enough) may be needed to see the effect.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy