Opened 7 years ago

Closed 3 years ago

#9616 closed Bug (fixed)

PasteFromWordRemoveStyles option doesnt work with ASP.NET control

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version:
Keywords: Cc:

Description

  1. Open FirstUse.aspx ASP.NET sample
  2. Set PasteFromWordRemoveFontStyles="False" and PasteFromWordRemoveStyles="False"
  3. Run the sample
  4. Paste contents from attached word file

Result: Notice that table background is not pasted but all the font styles are.

Possible cause:
If you see HTML of sample page you will notice that ony "pasteFromWordRemoveFontStyles" : false is present.
This is happening because (can be checked in Visual Studio) CKEditor ASP.NET control has PasteFromWordRemoveStyles set to false by default while in JavaScript editor this value is set to true.
Because PasteFromWordRemoveStyles="False" is treated by control as default value it is not being included in resulting JavaScript. Then default property which is set to true from config is being used instead. This result in missing styles.

To work around to the problem just put in ckeditor/config.js

config.pasteFromWordRemoveFontStyles = false;
config.pasteFromWordRemoveStyles=false;

Attachments (1)

word_table.docx (13.1 KB) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Jakub Ś

Attachment: word_table.docx added

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 5 years ago by Frederico Caldeira Knabben

Component: Server : ASP.NetPlugin : Paste from Word

comment:3 Changed 3 years ago by Tade0

Resolution: fixed
Status: confirmedclosed

Fixed with new Paste From Word plugin in 4.6.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy