Opened 7 years ago

Closed 7 years ago

#9619 closed Bug (fixed)

Bad toolbar margins with toolbarLocation = 'bottom'

Reported by: Frederico Caldeira Knabben Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.0
Component: UI : Skins Version: 4.0
Keywords: Cc:

Description

With the following configuration:

config.removePlugins = 'elementspath,resize';
config.toolbarLocation = 'bottom';

The toolbar should have the same margin space at the top and the bottom.

Additionally, the top space of the editor should not be rendered. It should be just a 1px line, just like the left and right borders. (Just like #9618)

Attachments (2)

Screenshot.png (10.9 KB) - added by Frederico Caldeira Knabben 7 years ago.
Issue screenshot.
9619.html (2.3 KB) - added by Olek Nowodziński 7 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 7 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: newassigned

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: Screenshot.png added

Issue screenshot.

Changed 7 years ago by Olek Nowodziński

Attachment: 9619.html added

comment:2 Changed 7 years ago by Olek Nowodziński

Added a sandbox for the issue.

comment:3 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

Pushed solution to t/9619@cksource. It also solves #9618.

Known issues:

  • IE7: Editor2 and Editor4 have double borders (respectively: top and bottom). I'm unable to get rid of them since the browser keeps displaying .cke_top/.cke_bottom even if they're empty with font-size = line-height = 0px, no margins and no paddings.
  • IE7/IE8: filter: progid:DXImageTransform.Microsoft.gradient is buggy and impacts parent borders (sic!). Sometimes they're invisible for .cke_top/.cke_bottom.

comment:4 Changed 7 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I confirm that this and #9618 are fixed with small issues you've mentioned that I think are acceptable.

However, I also noticed that paddings in toolbar changed, but I find this good. But lets have other guys' acceptance for this if this change was intended.

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Owner: changed from Olek Nowodziński to Frederico Caldeira Knabben
Status: review_passedreview

I tried to advice you guys earlier, as the root of the problem is something else, not CSS. Unfortunately the harder way of fixing it has been chosen and it is even buggy.

Additionally, the extra padding we have on Moono is a kind of skin signature, giving it a bit of relaxing. The new proposal (too late for it) makes everything more crowded.

I've coded a 5 mins fix for the border issue (#9618 as well), by recovering the v3 way for this. You can find it on t/9619b @cksource and @tests.

It's still missing a fix for the padding issue.

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewassigned

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

Owner: Frederico Caldeira Knabben deleted
Status: assignedconfirmed

I'm cancelling the review because in fact there is till not fix for the padding.

comment:8 Changed 7 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:9 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

Fixed padding issue with a commit into t/9619b.

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

The current padding on toolbar bottom and elements path has been changed. We should not change the current status of things - simply fix the issue that happens when changing the configuration as described.

comment:11 Changed 7 years ago by Olek Nowodziński

Status: review_failedreview

Updated t/9619b again.

comment:12 Changed 7 years ago by Garry Yao

With elementspath plugin loaded, this configuration results in a crowed bottom space (compared to v3)

comment:13 Changed 7 years ago by Piotrek Koszuliński

In v3 it doesn't look very well too.

I think that toolbar at the bottom makes sense only if elements path isn't loaded or if it's displayed at the top (that could be nice feature - they would create some kind of breadcrumbs).

comment:14 Changed 7 years ago by Piotrek Koszuliński

Status: reviewreview_passed

comment:15 Changed 7 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy