Opened 7 years ago

Closed 7 years ago

#9649 closed Bug (fixed)

Global variable leak ("i")?

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

1) I just noticed in Firebug some weird "i" variable. This variable is pretty popular, so I can image quite an interesting results of overwriting it accidentally

Can be reproduced on the nightly demo:

http://nightly-v4.ckeditor.com/demo/replacebyclass.html

2) after running the inlineall sample I see also data-cke-expando:

http://nightly-v4.ckeditor.com/demo/inlineall.html

Attachments (1)

data-cke-expando.png (45.6 KB) - added by Wiktor Walc 7 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 in reply to:  description Changed 7 years ago by Olek Nowodziński

window.i comes from htmldataprocessor.js, I cannot reproduce data-cke-expando issue though (dev/release).

I created a ticket #9652 to fix pending JSLint issues, to which window.i belongs.

comment:2 Changed 7 years ago by Wiktor Walc

Make sure to click into editable elemetns to launch CKEditor, in order to see this variable.

Changed 7 years ago by Wiktor Walc

Attachment: data-cke-expando.png added

comment:3 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: newclosed

The leaked variable is fixed by #9652, while the expando property seen on window is a unique DOM object identifier which cannot be removed (part of domobject impl.)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy