Opened 7 years ago

Closed 6 years ago

#9693 closed Bug (fixed)

UIColor picker doesn't change UI color on submit when "live preview" is switched off

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0.1
Component: UI : Skins Version: 3.0
Keywords: Cc:

Description

  • Open UI color plugin sample.
  • Open UI color picker.
  • Switch off "live preview".
  • Change color and submit.

Nothing has changed.

Change History (5)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed
Version: 4.0 (GitHub - master)3.0

This problem can be reproduced in all browsers from CKEditor 3.0

comment:2 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Opened git:1e75c31 for review. I just removed that checkbox, because it doesn't make any sense. UI color dialog without live preview is useless.

BTW. There was a typo - widget was named 'livePeview' :D.

comment:4 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

I created a simple test for the feature in t/9693 branch@ckeditor-tests-v4, which also should be merged.

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Masterised git:205c30e

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy