Opened 6 years ago

Closed 6 years ago

#9721 closed Bug (fixed)

Padding in content of div based editor puts editing area under bottom UI space

Reported by: Piotrek Koszuliński Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.0.1
Component: General Version: 4.0
Keywords: Cc:

Attachments (3)

div-editor-padding.png (124.3 KB) - added by Piotrek Koszuliński 6 years ago.
9721.html (5.4 KB) - added by Garry Yao 6 years ago.
Sample to reproduce
box-sizing-ie7.png (137.2 KB) - added by Piotrek Koszuliński 6 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by Piotrek Koszuliński

Attachment: div-editor-padding.png added

comment:1 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: newreview

Opened review e3ef009.

Changed 6 years ago by Garry Yao

Attachment: 9721.html added

Sample to reproduce

comment:3 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_failed

Unfortunately, IE7 doesn't support box-sizing:

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

Changed 6 years ago by Piotrek Koszuliński

Attachment: box-sizing-ie7.png added

comment:4 Changed 6 years ago by Olek Nowodziński

Owner: changed from Garry Yao to Olek Nowodziński
Status: review_failedassigned

comment:5 Changed 6 years ago by Olek Nowodziński

Status: assignedreview

Pushed solution to t/9721b, which is a hybrid of box-sizing (modern browsers) and positioning (IE7).

Accordingly extracted another related issue to #9812.

comment:6 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_failed

Unfortunately scrollbar on IE7@divarea sample behaves strangely.

comment:7 Changed 6 years ago by Olek Nowodziński

Status: review_failedreview

Pushed another solution to t/9721c, which solves IE7 issue with pseudo-expression code in divarea plugin. Since there's no single IE expression in editor CSS, I decided to not to pollute it and ported it into editor code.

Such JS solution (instead of CSS expression), however, brings safety concerns. For example, it can be violated by omitting relevant editor events. If possible, I'd suggest to use CSS expression or create a wrapper for .cke_wysiwyg_div or force-reset padding in IE7 (ugly idea).

The solution is based on the blog article.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

We couldn't find any safe pure-CSS patch for IE7 so based on a fact that P(IE7) * P(divarea) is extremely low we decided to gracefully degrade in this case by resetting vertical paddings to 0px.

Fixed on master with git:c824c5d.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy