Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#9734 closed Bug (invalid)

Spellchecker in Safari is not centered when main browser window is smaller than spellcheck window.

Reported by: Les Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.5
Keywords: Cc:

Description

I'm having trouble in Safari 5.x when the main browser window is smaller than the spellchecker. The spellchecker window actually does center on the viewable document, but then the window get scrolled down so that you lose part of the spellchecker window. Here's what to do to reproduce:

  • Open Safari 5.x, and reduce the window size so that a spellchecker window isn't going to fit it properly (probably 400px tall or so).
  • Browse to http://ckeditor.com/demo#full and scroll down until you see the CKEditor controls.
  • Click the Spellchecker button, then click Check Spelling.

This doesn't happen in Chrome, so I'm wondering if it's an actual bug in Safari or some possibly some code in CKEditor that is specific to Safari. that is causing the problem. If anyone can point me in the right direction to getting this fixed, that'd be fantastic. It wouldn't usually be a problem, but our content is in an iframe where the CSS overflow property is hidden and it's cutting the top of the document completely off without a scrollbar to remedy the situation. Thanks all!

Attachments (1)

12.png (134.9 KB) - added by Les 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Les

Attachment: 12.png added

comment:1 Changed 7 years ago by Les

This is for Windows 7.

comment:2 Changed 6 years ago by Jakub Ś

This issue can be observed in both Safari 5 and Safari 6 for MAC.

On one hand I’m wondering why dialog is not positioned according to viewport but whole page on the other I'm not sure if the approach with iframe 'overflow hidden' is valid. If there were 'scroll' property there wouldn't be a problem as dialog scrolls with whole page.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed
  1. Dialog has to be positioned according to page, not the viewport. Thanks to that if it is bigger than the viewport, you can still see entire dialog by scrolling the page.
  2. I cannot reproduce this issue for any other dialog. The thing is that Spellchecker dialog isn't created by CKEditor code, but by 3rd party plugin. Thus this issue should be reported on Webspellchecker's Github page.

comment:4 Changed 6 years ago by Jakub Ś

  1. @Reinmar is right this is only happening with WSC dialog thus it is possible that thier code might be causing this jump.
  2. @les.buchanan you might want to reconsider using scroll bars in your iframe. Like I have said before dialogs are designed that way to scroll with whole page which IMHO would solve your problem.
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy