Opened 7 years ago

Closed 7 years ago

#9742 closed Bug (worksforme)

IE8 Quirks mode -Javascript Unspecified error after pluged the SCAYT into editor

Reported by: sasi Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 4.0.1
Keywords: Cc: WebSpellChecker.net

Description (last modified by Jakub Ś)

Javascript Unspecified error. at line: 6964 after pluged the SCAYT into editor

it is working fine in Chrome, Firefox, Safari. Same error occurs when using version 3.6.6 saying "unspecified error in _base.xd.js . at line: 6964". I have attached the screen shot.

Attachments (2)

IE8_Error.GIF (18.1 KB) - added by sasi 7 years ago.
IE8.JPG (57.9 KB) - added by sasi 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by sasi

Attachment: IE8_Error.GIF added

comment:1 Changed 7 years ago by Jakub Ś

Cc: WebSpellChecker.net added
Component: File BrowserUI : Spell Checker
Description: modified (diff)
Summary: Problem while loading editor in IE8 .Javascript Unspecified error. at line #6964 after pluged the SCAYT into editorIE8 Quirks mode -Javascript Unspecified error after pluged the SCAYT into editor

comment:2 Changed 7 years ago by Jakub Ś

Status: newpending

Judging by icons you are using quirks mode.

I have tried to run CKEditor 4 with config.scayt_autoStartup = true; and simply turning it on. It has worked without problems.

What are exact steps to reproduce problem in plain CKEditor (not in your application) in IE8.

I'm waiting for your comment @sasihmca.

comment:3 in reply to:  2 Changed 7 years ago by sasi

Thanks for your quick reply.

i placed and execute the SCAYT Plugin as described in README.md file.

Initially i got error ,'icons' is null ,Not an object error.Then i added the required plugin files namely(menu,menubutton,button,panel,floatpanel).

If i use config.scayt_autoStartup = true;, unspecified error occurs while loading editor.But i set this parameter as false and error occurs only after i click the "Enable SCAYT" .

Advice me,if i missed to add/change settings for CKeditor 4 other than specified in README.md and also how to use in quirks mode.

thank you

comment:4 Changed 7 years ago by Jakub Ś

Version: 4.04.0.1 (GitHub - master)

Please note that there is no full support for IE quirks mode in IE, what you can see E.g. when looking at icons, but this particular part works.

To get it working in your case, please go to CKEditor builder http://ckeditor.com/builder, choose any version, and in plugins list please select SCAYT (and any other plugin you want E.g. wsc if it is needed). Then run editor in quirks mode. Does this work for you?

comment:5 in reply to:  4 Changed 7 years ago by sasi

hai,

i build only SCAYT using builder and install ckeditor. Again i got the same "unspecified error ". i attach the screenshot(IE8.jpg).

Thank you

Last edited 7 years ago by sasi (previous) (diff)

Changed 7 years ago by sasi

Attachment: IE8.JPG added

comment:6 Changed 7 years ago by Jakub Ś

  1. Are you able to reproduce this on any other computer? I was not able on two so perhaps the problem is in your machine or browser and not editor. Could you recheck and leave a comment.
  2. As for the browser – you may have some non-default settings that cause this. Could you check this as well? Could you perhaps reset IE to default and then try?
  3. How do you check quirks mode? Is it by setting IE dev tools to quirks mode (invalid because sometimes you get different results than in browser) or by removing doctype declaration (correct)?

Please replay to all three questions.

comment:7 Changed 7 years ago by Piotrek Koszuliński

Resolution: worksforme
Status: pendingclosed

OK, neither Kuba nor I can reproduce this issue so I'm closing it. If you'll provide us a sample proving that this issue still exists we'll reopen this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy