Opened 6 years ago

Closed 5 years ago

#9776 closed New Feature (fixed)

Contents.css: set tab size 4

Reported by: Olek Nowodziński Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 4.0.1
Keywords: Cc:

Description

The idea is to set tab size property to 4 (instead of 8) for editor contents.

Pros:

  • Contents look more like a "code editor".
  • Less line wraps.
  • Eyecandy.

Cons:

  • Old browsers don't support such thing so the formatting may depend on the browser.

Change History (5)

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0.1

comment:2 Changed 6 years ago by Jakub Ś

Status: newconfirmed

Old browses will always be a pain.

One good technique IHMO is allowing nice features in supporting browsers and leaving default behaviour in the rest thus this sounds like good idea.

comment:3 Changed 5 years ago by Piotrek Koszuliński

Why would we set tab-size:4 for editor contents? Did you mean <pre> elements contents? Or source area?

comment:4 in reply to:  3 Changed 5 years ago by Olek Nowodziński

Replying to Reinmar:

Why would we set tab-size:4 for editor contents? Did you mean <pre> elements contents? Or source area?

It's been a while since we discussed it but I still believe this suppose to happen in source area.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

So it's been done a long time ago :D

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy