Opened 6 years ago

Closed 6 years ago

#9839 closed Bug (wontfix)

DIV with id="content"

Reported by: Sergey Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: IE Cc:

Description

If a page contains a div element with id="content", the CkEditor picks up the contents of the element and puts it into the editor area.It works in IE7 only.

Attachments (3)

test.html (1.4 KB) - added by Sergey 6 years ago.
Capture.PNG (64.6 KB) - added by Sergey 6 years ago.
A screebshot of the test page
_content.html (1.4 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Sergey

Attachment: test.html added

Changed 6 years ago by Sergey

Attachment: Capture.PNG added

A screebshot of the test page

Changed 6 years ago by Jakub Ś

Attachment: _content.html added

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 4.04.0 Beta

Problem has been reproducible from CKEditor 4 beta in IE7 only.

Currently (current master) I'm able to reproduce this problem in every IE (IE7-10).

Just copy the attached _content.html into samples folder and open it in IE.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.2

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Note that this happens with all IEs in Compatibility View only.

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

The root of the problem is that, in IE7 and earlier, getElementById is case-insensitive, so having two elements with the same id breaks things.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0.2
Resolution: wontfix
Status: confirmedclosed

Considering the above, there is not clear way to have it fixed at CKEditor side. The only solution would be avoiding using getElementById and loop through all elements until a case-sensitive match on id is not found. This is of course impracticable.

The proper way to have it fixed is in fact avoiding duplicating case-insensitive ids in the page.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy