Opened 7 years ago

Closed 7 years ago

#9864 closed Bug (fixed)

[IE10] Paste results in "Object doesn't support property or method 'createRange'"

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone: CKEditor 3.6.6
Component: Core : Selection Version: 3.6.6
Keywords: IE10 Cc:

Description (last modified by Wiktor Walc)

Steps to reproduce (1)

Open Special Character and try inserting any character.

Result:

SCRIPT438: Object doesn't support property or method 'createRange' 
wysiwygarea/plugin.js, line 125 character 4

Steps to reproduce (2)

  1. Open _samples/api.html
  2. Click "Insert HTML" button

Result as above.

Steps to reproduce (3)

<p>
	Sample <img src="http://b.cksource.com/a/1/img/sample.jpg" /> image</p>
  1. Select an image
  2. Press Ctrl + X (cut), then Ctrl + V (paste)

Result as above.

Change History (4)

comment:1 Changed 7 years ago by Wiktor Walc

Description: modified (diff)

comment:2 Changed 7 years ago by Wiktor Walc

Description: modified (diff)

comment:3 Changed 7 years ago by Jakub Ś

Keywords: IE10 added; IE removed
Status: newconfirmed

This issue can be reproduced in IE10 only from CKE 3.6.6 rev. [7662]. This is another issue caused by this revision (#9865).

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.6
Resolution: fixed
Status: confirmedclosed

Reverted [7662] with [7684].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy