Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9913 closed Bug (invalid)

CKEditor Content Not Submitting Properly

Reported by: Jeremy Perry Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description

I noticed a problem with using CKEditor Framed editing. When I try to save the content, my server-side gets a blank post from the page. This is also true when I did a client-side jQuery check on the textarea. The page I am working on is AJAX-based and is able to save the content if there is a submit issue. When I try to submit the page again, the content will submit. I ensured it wasn't my setup by turning off the CKEditor replace function on the textarea, and I was able to submit anything plain text without a problem. I like the 4.0 features, but this bug is unfortunately going to prevent me from letting my application use the tool. Please let me know if there is anything I can do to resolve this problem, or if a bug fix becomes available.

Change History (5)

comment:1 Changed 7 years ago by Jeremy Perry

Just to add as a comment. I am using Mac OS X 10.7. I found this issue on both the latest versions of Firefox and Chrome.

comment:2 Changed 7 years ago by Piotrek Koszuliński

I don't fully understand your case. Can you provide a sample that shows this issue?

My guess is that you're trying to retrieve data from textarea on which CKEditor was built. This is incorrect way. It works only when you submit a form in which this textarea is placed. When you want to submit content via AJAX then you should:

If I'm right, please let me know, so I can close this ticket.

comment:3 Changed 7 years ago by Piotrek Koszuliński

Status: newpending

comment:4 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

@Reinmar I think you are right because this is the same thing I have thought after I had read this ticket.

@jeremyrperry if despite changes you still can't get this working please write prepare sample page that allows reproducing this problem in CKEditor and I will reopen this ticket.

comment:5 Changed 7 years ago by Jeremy Perry

I got the problem solved. I was used to working with an older version of CKEditor where this step wasn't necessary. The ticket can be closed. Thanks!

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy