Opened 7 years ago

Closed 6 years ago

#9933 closed Bug (duplicate)

Shift+Enter or Enter in Enter_BR breaks color style

Reported by: fabrizio Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.3
Keywords: IBM Cc: Teresa Monahan, Damian, Satya Minnekanti

Description

Steps to reproduce:

  1. Type a sentence
  2. Shift+enter
  3. Select color (either text or background)
  4. Type another sentence
  5. Shift+enter
  6. Select again another color (either text or background)
  7. Type another sentence

Expected result: Line 1 (normal text), line 2 (colored text), line 3 (colored text).

Actual result: Line 1 (normal text), line 2 (normal text), line 3 (colored text).

Change History (9)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newconfirmed
Version: 4.0.2 (GitHub - master)3.6.3

I was able to reproduce this on 4.0, 4.0.1 and 3.6.x from at least [7400]. Before that shift+enter around step 5. caused different issue.

I'm setting version=3.6.3, but more accurate search is needed.

comment:2 Changed 7 years ago by Jakub Ś

This particular TC has been reproducible from CKEditor 3.6.3 rev. [7392].

From CKEditor 3.2.1 till CKEditor 3.6.3 rev. [7391] it was not possible o to change color set in point 3.

This has worked till CKEditor 3.2.

comment:3 Changed 7 years ago by Teresa Monahan

This happens in both P and DIV entermode. It also occurs in BR enterMode by using enter instead of Shift+enter in step 2 and 5 above.

comment:4 Changed 7 years ago by Jakub Ś

Summary: Shift+Enter breaks color styleShift+Enter or Enter in Enter_BR breaks color style

comment:5 Changed 7 years ago by Jakub Ś

#9970 was marked as duplicate.

TC from that ticket - It works the same inline styles like bold

  1. Clear all text
  2. Write a line of text
  3. Select this line
  4. Click bold (first line becomes bold)
  5. Press enter to make a new line
  6. Click bold again to disable it

In every version after 3.6.3, including 4.x, after last step bold for the first line is removed.

comment:6 Changed 7 years ago by Jakub Ś

It seems we have few more tickets caused by this revision: #9009, #8980, #8942.

comment:7 Changed 7 years ago by Jakub Ś

Please have a look at #9970. User @agentcooper is proposing fixes that might point someone to the right direction.

comment:8 Changed 6 years ago by Jakub Ś

DUP of #9009.

comment:9 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy