Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9942 closed Bug (invalid)

FCKeditor FileManager IE10 Compatibility

Reported by: cheesypoof Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE10 Cc:

Description

Any chance of FCKeditor's FileManager receiving a patch for IE10 compatibility? It's still a great free file uploader.

I receive an error which prevents files and folders from being listed:

SCRIPT438: Object doesn't support property or method 'selectSingleNode' 
fckxml.js, line 136 character 3

Thanks

Change History (16)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE10 added
Status: newpending

I have just tried latest FCKeditor 2.6.9 in IE10 compatibility (it works in IE8 and below modes) and had no problems.

Which version do you use? Is it the latest 2.6.9?
What are exact steps to reproduce this problem?

comment:2 Changed 7 years ago by cheesypoof

  1. I downloaded 2.6.9 from SourceForge and extracted all files to my WAMP localhost server.
  2. Visited http://localhost:8080/fckeditor/_samples/default.html in Firefox and clicked 'Insert/Edit Image' and then 'Browse Server'.
  3. Uploaded a few files and created directories.
  4. Copied FileManager popup url: http://localhost:8080/fckeditor/editor/filemanager/browser/default/browser.html?Type=Image&Connector=http%3A%2F%2Flocalhost%3A8080%2Ffckeditor%2Feditor%2Ffilemanager%2Fconnectors%2Fphp%2Fconnector.php and visited it in IE10.
  5. Receive error and consequently no files/folders are listed.

I would have done the first 3 steps with IE but I receive a similar error in FCKeditor:

SCRIPT438: Object doesn't support property or method 'selectSingleNode' 
fckeditorcode_ie.js, line 68 character 1021

I also have a hosted FileManager integrated with CKEditor 4 for which I receive the same error in IE10.

comment:3 Changed 7 years ago by cheesypoof

Oops I forgot after Step 1 that I set in the PHP connector config file:

$Config['Enabled'] = true ;

comment:4 Changed 7 years ago by Jakub Ś

Looking at your above post we can say in short that you have used default FCKeditor and it didn't work for you.

I have tried that too and it worked without problems.
I have tried copying URL like you or simply using editor in IE10 compatibility mode and without.

Perhaps there is a difference in browser? Are you using Win8 and IE10 or some tool that acts like IE10 or perhaps in8 preview mode?

comment:5 Changed 7 years ago by cheesypoof

I am using IE10 on Windows 7. I guess this version has a bug. Apologies for any inconvenience.

comment:6 Changed 7 years ago by Jakub Ś

I am using IE10 on Windows 7

But isn't IE10 for Win7 just a release preview? I have only seen it available (since November 14 2012) as such. I haven't seen any ready to use IE0 for win7 nor were there any updates for Win7.

If we are talking about release candidate then I would suggest waiting for final product. Could you confirm/deny this?

comment:7 Changed 7 years ago by cheesypoof

I am using the release preview, which I mistakenly thought was more finalized than it apparently is... You're right it would be prudent to wait for the final release.

comment:8 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Thanks for information. I'm closing ticket for now.

If you have any problems in final IE10 for Win7 please report them.

comment:9 Changed 6 years ago by cmorris

Hi, I'm new to ckeditor's website, but found this ticket during a search online for assistance with the same problem.

However, unlike the last part mentioned by Cheesypoof - at the end of March (2013) and currently in the present (April) our windows 7 PC's are automatically upgrading IE to version 10 during the normal windows updates and without approval from the user.

Though the updates are set to require approval by the user first - it still updates.

This leaves us with a non-working IE. None of our users are able to access the web. Once they click on the IE icon it is a blank white screen they get and even if they try to enter a url address the cursor just spins.

We've been having to undue the upgrade and put everyone back to IE 9 for them to be able to access our sites, etc.

I have no idea if this is the final IE10 for Win 7 or not. I would assume since it updates on it's own that it is.

If I need to open a new ticket - please let me know, but since I thought this went along with this ticket - I've just added the message here.

Any help would be greatly appreciated! :-)

Thanks, cmorris cmorris@…

Last edited 6 years ago by cmorris (previous) (diff)

comment:10 Changed 6 years ago by Jakub Ś

@cmorris FCKeditor is not supported anymore. It will be harder and harder to make it working with new browsers and HTML5. I have forwarder you comment to my colleague. Decisions here are still to be taken whether drop FCK support or keep it alive as long as possible.

Please note that current version is CKEditor 4 - created to work with HTML5. If you worry about File browser then please note that we don't force users to use CKFinder. They can always file browser they create or open-source file browser (if such exists).

Workaround for FCKeditor and IE10 is using on HTML page this tag <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />. It will force IE10 document mode into IE7. Browser will be IE10 but doc mode IE7 and it will work. The only problem I had with this workaround was making IE read this tag. I had to clear browsers cache because it was loading page with old settings. Anyway it works.

comment:11 Changed 6 years ago by cmorris

Hi J.swiderski,

I think I am confused - could you clerify if upgrading to CKEditor 4 from FCKeditor will fix our web browser (IE version 10) to be able to viwe our campus website and subsequent sites or not?

Is FCKeditor something that is only installed on a webserver or the individual PC's or in the Internet Explorer inner workings?

I'm trying to figure out how to fix this across the board for all our users on our campus. Any help and advice or links are very much appreciated!

Thanks! Constance

comment:12 Changed 6 years ago by Jakub Ś

upgrading to CKEditor 4 from FCKeditor will fix our web browser (IE version 10)

This won't fix web browser:)

You have told me that you have problems with FCKeditor on latest IE10.

  1. IE10 was developed quite recently and its standard mode works with HTML5. FCKeditor was developed long time ago in times of HTML and something may not work as expected.
  2. Recommended solution is using CKEditor 4 as it is most suited for modern browsers and HTML5. We don't support FCKeditor anymore.
  3. If you want to stay with FCKeditor please try using <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />. It will put IE document mode in to IE7 and will work. Browsers mode will be IE10 but documents mode will be IE7.

comment:13 Changed 6 years ago by cheesypoof

I just wanted to follow up on this ticket now that the final IE10 release is available; FCKeditor and the included file browser still break in IE10 (IE10 document mode) on Windows 7. I completely understand if a fix isn't doable because of the age of the FCKeditor code. Thanks again!

Last edited 6 years ago by cheesypoof (previous) (diff)

comment:14 Changed 6 years ago by Mitchell

I ran across this problem myself and was able to get the FCKEditor file manager working in IE10.

In /editor/filemanager/browser/default/js/fckxml.js look for

oXmlHttp.send( null ) ;

After this line, add:

try { oXmlHttp.responseType = 'msxml-document'; } catch(e){}

In IE10, XMLHttpRequest no longer sends XML as an MSXML document and thus, selectNodes and selectSingleNode aren't available. The line above forces the responseType to be an MSXML document if it is supported. Read more about it here: http://blogs.msdn.com/b/ie/archive/2012/07/19/xmlhttprequest-responsexml-in-ie10-release-preview.aspx.

comment:15 Changed 6 years ago by Joel

Weather or not FCK is supported, the CKF site still has a demo for it that fails with IE10: http://cksource.com/ckfinder/demo#fckeditor

I suggest just to remove the demo if it's not supported :)

comment:16 Changed 6 years ago by Jakub Ś

@req well, that's a pretty good point. We shouldn’t keep old and not supported version on our demo page.

Thank you.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy