Opened 12 years ago

Closed 6 years ago

#997 closed Bug (fixed)

Wrong position of panel on fixed positioned toolbar

Reported by: Lukasz Frankowski Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: FCKeditor 2.4.3
Keywords: Cc:

Description

We have the fckeditor toolbar located on outer div which is 'fixed' positioned (in gecko browser), in order to be global for the website. So, our:

oFCKeditor.Config[ "ToolbarLocation" ] = "Out:fckToolbar";

In this case the toolbar panels (eg. the font panel) are not positioned correctly. I have found the place in the code, which should be changed to fix it, but I have no time for now to look in the code for the style of toolbar panel container to create conditional clause, depended on the container position, but the fckeditor developers won't have a problem to insert the code like this there:

oIFrame.style.position = 'absolute';
if (fckeditor.toolbar.container.style.position == 'fixed')
  oIFrame.style.position = 'fixed';

The location of bug is indicated in attached fckpanel-fixed-position-bug.js file.

Attachments (1)

fckpanel-fixed-position-bug.js (8.6 KB) - added by Lukasz Frankowski 12 years ago.
The toolbar panel fixed position bug indication.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by Lukasz Frankowski

The toolbar panel fixed position bug indication.

comment:1 Changed 12 years ago by Lukasz Frankowski

I've realized that it's not so easy, because the panel is used in the editor context menu as well. So the solution must be more sophisticated, eg. looking upwards DOM hierarchy starting from panel parent, for the element fixed positioned, to set its position to 'fixed'?

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: panel position fixed removed

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:4 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I believe this bug is gone because shared spaces feature was introduced in CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy