Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#5021 closed Bug (fixed)

Automatic insertion of <br /> in Firefox when using enterMode = BR;

Reported by: sushniak Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.2
Keywords: Firefox Confirmed Review+ Cc: alexander_jared@…, russellh@…

Description

In Firefox (I'm using 3.5.7, but other people from cksource forum say that in version 2.0 and 3.0 happens the same) in empty ckeditor window, in all versions starting from 3.0 to 3.1, while using config.enterMode = CKEDITOR.ENTER_BR;, is being inserted <br /> at the start of the document and when starting to type - you do it from a second line already.

In the other browsers (I've checked in all IE- 6,7,8, Opera, Chrome, Safari) it seems to be OK.

Topics: http://cksource.com/forums/viewtopic.php?f=11&t=16578 http://cksource.com/forums/viewtopic.php?f=11&t=17195

Attachments (1)

5021.patch (2.8 KB) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 6 years ago by jared

  • Cc alexander_jared@… added

comment:2 Changed 6 years ago by alfonsoml

  • Keywords Firefox added; firefox enter_br removed
  • Milestone CKEditor 3.2 deleted
  • Priority changed from High to Normal

comment:3 Changed 6 years ago by russh

  • Cc russellh@… added

comment:4 follow-up: Changed 5 years ago by garry.yao

  • Resolution set to expired
  • Status changed from new to closed

Unable to reproduce anymore on 3.2.
Feel free to reopen the ticket on any new discoveries.

comment:5 in reply to: ↑ 4 Changed 5 years ago by sushniak

Replying to garry.yao:

Unable to reproduce anymore on 3.2.
Feel free to reopen the ticket on any new discoveries.

Sorry, but it still does. I've checked on 3.2 version 5205 build. Firefox 3.6

comment:6 Changed 5 years ago by sushniak

  • Resolution expired deleted
  • Status changed from closed to reopened
  • Version changed from 3.1 to 3.2

comment:7 Changed 5 years ago by matti

Related #5341 ?

comment:8 Changed 5 years ago by sushniak

  • Resolution set to fixed
  • Status changed from reopened to closed

http://dev.fckeditor.net/ticket/5341 That one has resolved the problem

comment:9 Changed 5 years ago by garry.yao

  • Keywords Confirmed added
  • Milestone set to CKEditor 3.3
  • Resolution fixed deleted
  • Status changed from closed to reopened

This's a regression brought by [3816], actually the original solution at #3864 should be re-proposed due to the following factors:

  1. Recent dialog change from [5140] has broken the current solution which is trying to fix the problem on 'focus' of document (dialog open no longer cause editor to gain focus).
  2. The selection is not been properly handled after the fix so problem reported at this ticket was happening.

Changed 5 years ago by garry.yao

comment:10 Changed 5 years ago by garry.yao

  • Keywords Review? added

By confirming this particular FF bug only affects newly opened document, it should be safe to carry out the fix by time the editing frame is reloaded.

comment:11 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from reopened to new

comment:12 follow-up: Changed 5 years ago by alfonsoml

  • Keywords Review- added; Review? removed

That doesn't fix the problem for me.

comment:13 Changed 5 years ago by alfonsoml

#5420 has been marked as dup

comment:14 in reply to: ↑ 12 Changed 5 years ago by garry.yao

  • Keywords Review? added; Review- removed
  • Status changed from new to assigned

Replying to alfonsoml:

That doesn't fix the problem for me.

WFM in both FF2 and FF3, can you provide more details of the failure?

comment:15 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

The patch fixed it for me also. Tested with FF3 and FF3.6.

comment:16 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5389].

comment:17 Changed 5 years ago by technotarek

  • Resolution fixed deleted
  • Status changed from closed to reopened

I've applied the patch, but it doesn't seem to resolve the problem. I have a page with multiple instances of CKeditor. Each instance is loaded by applying "class='ckeditor' to a textarea. In Firefox 3.6.3, a <br /> tag is written to each text area as soon as each editor is initialized. Obviously, if the values are then written to a database, the break tag gets written. there is no way to write an empty value.

I've confirmed that the problem doesn't happen in Chrome and as many others have pointed out in the forums, it doesn't appear to happen with IE either.

Please advise and and thanks in advance.

comment:18 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from reopened to closed

Please use our SVN trunk and latest nightly build to verify the status of bugs.

comment:19 Changed 5 years ago by technotarek

  • Resolution fixed deleted
  • Status changed from closed to reopened

Bug confirmed, using latest nightly build. I used the sample at http://nightly.ckeditor.com/latest/ckeditor/_samples/replacebyclass.html and then did the following:

  1. Cleared the contents using new page
  2. Click and unclick the source button twice; click a third time to see the added <br /> tag.

Although there is no way of testing it, I suspect loading a page with an editor that is supposed to have no data will include the <br /> as well.

Bug confirmed on Mac FF (3.6.3) and PC FF (3.6.3). Bug does not appear in Chrome.

comment:20 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from reopened to closed

Note that the bug you're reporting is a duplicate of #5293 for me, while the bug described by this ticket is an extra visual line introduced in wysiwyg mode, not related to the <br /> in output.

comment:21 Changed 5 years ago by technotarek

My apologies. I searched for that original ticket but couldn't find it and thought the two had merged. Thanks for replying.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy