Ticket #5422 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

[[IE]] we can't enter the text below Page break

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.2
Keywords: IBM Confirmed IE Cc: damo,joek

Description

To reproduce the defect

  1. Open Ajax sample.
  1. Type some text and Click on Insert Page break for Printing button.
  1. See that Page break is inserted in the Editor.
  1. Try to position the Cursor after the page break using Mouse or Key board.

Expected Result:

We should be able to position the cursor after the page break using mouse or key board and we should be able to type the text after Page break.

Actual Result:

Cursor is still shown above the Page break and we can't position the cursor after page break.So we won't be able to type the text after page break.

Change History

comment:1 Changed 4 years ago by garry.yao

  • Keywords Confirmed added

#5285 has been marked as duplicated.

comment:2 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from new to assigned

Supposed to be fixed by #5381.

comment:3 Changed 4 years ago by fredck

  • Status changed from assigned to closed
  • Resolution set to worksforme

Confirmed with version 3.2. WFM with the current trunk.

comment:4 Changed 4 years ago by satya

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I have tested this against nightly build and i could still re produce this on IE 6 & IE 7

comment:5 Changed 4 years ago by fredck

  • Keywords IE added

It instead work, at least with the mouse. The problem is that, due to IE limitations, the user needs to click quite close the the page break line. Just clicking lower in the blank space at the end of the contents is not enough.

We can change the command behavior to make it work like the Insert Horizontal Line button, placing the caret after it in a new paragraph when inserting the page break.

comment:6 Changed 4 years ago by garry.yao

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed with [5338].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy