Ticket #6466 (closed Bug: expired)

Opened 4 years ago

Last modified 2 years ago

Error while switching from WYSIWYG to source view in IE 8

Reported by: raghavendra.ps Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Cc:

Description

Hi,

I have integrated Ckeditor in to a webpage.

It will loads fine. After loading even if we do single click on the WYSIWYG Editor area and try to switch to Source view by clicking on the source view button, the editor will show blank.

Nothing will work after this.

I can see the below javascript error.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; FDM; .NET CLR 2.0.50727; .NET CLR 1.1.4322) Timestamp: Thu, 14 Oct 2010 09:01:35 UTC

Message: Unknown runtime error Line: 16 Char: 415 Code: 0 URI: http://localhost/lcms/ckeditor/ckeditor.js

Another scenario where I'm getting the same Error

Enable the SCYAT and switch to Source view also not allowing the editor to show any data and the error as follows

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; FDM; .NET CLR 2.0.50727; .NET CLR 1.1.4322) Timestamp: Thu, 14 Oct 2010 09:08:44 UTC

Message: Unknown runtime error Line: 16 Char: 415 Code: 0 URI: http://localhost/lcms/ckeditor/ckeditor.js

Message: 'K' is null or not an object Line: 92 Char: 1275 Code: 0 URI: http://localhost/lcms/ckeditor/ckeditor.js

This is happening only in IE 8.

can you please take a look on this issue.

If you needed any more info, feel free to reply me.

Regards, Raghavendra.

Attachments

debugger_error.docx (109.0 KB) - added by raghavendra.ps 4 years ago.
page_source.txt (9.6 KB) - added by raghavendra.ps 4 years ago.

Change History

comment:1 Changed 4 years ago by alfonsoml

  • Status changed from new to pending

Please, provide a page to reproduce the problem.

comment:2 follow-up: ↓ 3 Changed 4 years ago by raghavendra.ps

Hi,

we Integrated CKeditor in to our Page.

In our environment it is not working.

Is there any possibility that Ckeditor dev team can have a look on this Issue using web-ex.

or is there any other way? If so suggest us.

Regards, Raghavendra.

comment:3 in reply to: ↑ 2 Changed 4 years ago by raghavendra.ps

Hi,

Please let us know is there any possibility that if we raise a web-ex to show our environment, you guys can join and to have a look on this issue.

Regards, Raghavendra.

Replying to raghavendra.ps:

Hi,

we Integrated CKeditor in to our Page.

In our environment it is not working.

Is there any possibility that Ckeditor dev team can have a look on this Issue using web-ex.

or is there any other way? If so suggest us.

Regards, Raghavendra.

comment:4 follow-up: ↓ 5 Changed 4 years ago by alfonsoml

This is a public tracker, so your best chance is to provide a public test. Of course, it must be done using the latest published version, not 3.0

Changed 4 years ago by raghavendra.ps

Changed 4 years ago by raghavendra.ps

comment:5 in reply to: ↑ 4 Changed 4 years ago by raghavendra.ps

Replying to alfonsoml:

This is a public tracker, so your best chance is to provide a public test. Of course, it must be done using the latest published version, not 3.0

I have attached the source of the page where the issue occurs and the debugger screen shot for your reference.

I doubt that the issue could be because of conflict with java script files included in the page. I say this because, the editor works fine in another context in our application.

Please take a look and provide your opinion.

comment:6 Changed 4 years ago by alfonsoml

I can't manage to load anything with that sample page.

Can you provide one that doesn't depend on all those external files?

comment:7 Changed 2 years ago by webhelio

I am seeing this same error in IE 8, and IE 7, but only on Windows XP if that makes a difference. The way it happens for me is when I click on the source button if I do not move the mouse at all then I can see the source, but as soon as I move the mouse the editor goes blank completely and I cannot see source code at all.

comment:8 Changed 2 years ago by alfonsoml

Again: Can you provide a testcase to reproduce the problem?

comment:9 Changed 2 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy