Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#6540 closed Bug (fixed)

Safari: AutoGrow plugin - CKEditor loses focus

Reported by: wwalc Owned by:
Priority: Normal Milestone: CKEditor 3.6.2
Component: General Version: 3.4
Keywords: IBM Safari Mac Cc: satya_minnekanti@…

Description

When testing the AutoGrow sample attached with CKEditor using Safari 5.0.2 @ Mac, you'll notice that whenever the editing area is resized, CKEditor is losing focus and it is impossible to type anything until you click back onto the editing area.

Change History (12)

comment:1 Changed 6 years ago by wwalc

  • Status changed from new to confirmed

comment:2 Changed 6 years ago by garry.yao

  • Status changed from confirmed to pending

WFM with Safari5/Windows.

comment:3 Changed 6 years ago by wwalc

WFM as well in Safari 5.0.2 @ Windows.

comment:4 Changed 6 years ago by krst

under safari4 and safari 5 @ Mac since cke 3.4:

  • select _samples/autogrow
  • set focus to editor "with maximum height 400"
  • keep pressing enter
  • when new line is inserted at the bottom of edit area, whole page scrolls up, focus is lost

comment:5 Changed 5 years ago by wwalc

  • Status changed from pending to confirmed

I'm still having this issue in current trunk using Safari 5.0.3 @ Mac. Works fine in Chrome.

comment:6 Changed 5 years ago by inspire22

Any fix for this? It's driving my users nuts!

comment:7 Changed 5 years ago by wwalc

  • Milestone set to CKEditor 3.6.1
  • Resolution set to fixed
  • Status changed from confirmed to closed

#7036 was marked as duplicate.

It looks like this issue was fixed by [6921].

comment:8 Changed 5 years ago by wwalc

  • Milestone CKEditor 3.6.1 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening because [6921] has been reverted.

comment:9 Changed 5 years ago by j.swiderski

  • Keywords IBM added
  • Status changed from reopened to confirmed

This issue has been duplicated in #6969.

In that issue, @satya has also noticed that when you place cursor inside editor body again and press Backspace or Delete button to remove paragraphs that caused autogrow to fire, the focus is also lost.

comment:10 Changed 5 years ago by satya

  • Cc satya_minnekanti@… added

comment:11 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from confirmed to closed

This's now fixed by #6212.

comment:12 Changed 5 years ago by wwalc

  • Milestone set to CKEditor 3.6.2
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy