Ticket #6634 (closed Bug: worksforme)

Opened 4 years ago

Last modified 4 years ago

Nested list in RTL is incorrectly presented

Reported by: garry.yao Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.5.1
Component: Core : BiDi Version: 3.4
Keywords: IBM Cc: jamcunni@…

Description

Nested list like the following looks wrong in editor as there's no desired margin on the right side to differs from the 1st level list.

<ul>
	<li>
		List item 1 (LTR)
		<ul>
			<li dir="rtl">
				List item 2 (RTL)</li>
		</ul>
	</li>
	<li>
		List item 3 (LTR)</li>
</ul>

Change History

comment:1 Changed 4 years ago by garry.yao

  • Status changed from new to confirmed
  • Cc jamcunni@… added

The problem is originally been reported here.

comment:2 Changed 4 years ago by fredck

This issue can be easily worked around by CSS. My opinion is that we should add the necessary rules to the contents.css file, without bloating the editor code.

comment:3 Changed 4 years ago by james c

  • Keywords IBM added

comment:4 Changed 4 years ago by garry.yao

Supposed to be fixed by #6249.

comment:5 Changed 4 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from confirmed to assigned

It's not fixed by #6249.

comment:6 Changed 4 years ago by tobiasz.cudnik

  • Status changed from assigned to closed
  • Resolution set to worksforme

Actually, after second check it indeed is fixed by #6249.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy