Ticket #6643 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Ctrl+V on Windows XP with FF pastes local image

Reported by: mb@… Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.0
Keywords: Discussion Cc:

Description

Hi, I'm mike from the OTRS project. We use CKEditor in our open source software, and generally our users are really happy with it.

One thing that we found out recently is that if you're on Windows, with Firefox 3,6, you can paste an image in the editor by clicking Ctrl+v on the keyboard. If you do this on Win7 or WinVista, then the result is a broken image icon diplayed in the editor. If you look at the source there's an <img> tag which points at the file in the users temp dir on the local hard drive.

However, if you use Firefox 3.x on WinXP apparently the image IS displayed properly inside the editor so it LOOKS like the image is there, only obviously the path is still local. This is nastier because the user THINKS it worked, and submits the entry. Only for anyone using a different PC the file is not in this location, so they don't see the image.

Inserting an image using the image button in the CKEditor toolbar works just fine.

1.) CKeditor should stop making Ctrl+v with image data on the clipboard insert broken <img> tags?

2.) since apparently the link to a file is available, it would be great if this same action could open the image dialog with the link to the local file pre-populated.

We even have users who reported that it works for them already in the way described in 2) just I could not find the browser/OS combination to reproduce that.

Change History

comment:1 Changed 4 years ago by garry.yao

  • Keywords Discussion added; windows image firefox removed
  • Version changed from 3.4.2 to 3.0
  • Component changed from General to Core : Pasting

Check out #4069 for more info about the way how browser handles local image, though we could think about having detected local images stripped on pasting.

comment:2 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to fixed

I have checked in Win XP in latest CKEditor 3.6.2 and latest Firefox 3.6.24 and the bug seem to fix itself.

Doesn't matter whether you copy file from file system or from browser because when you paste it with CRTL+V you can only see broken image icon.
When you switch to source you can see that "src" attribute starts with "file://"

In newer Firefox browsers (<4) this is not the case anymore as they use "data:image" attribute.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy