Ticket #7883 (closed Bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

[Opera] Context menu appears for toolbar button double-click

Reported by: fredck Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Opera Cc: hallvord@…

Description

  1. With a default sample, double-click the "some" word to select it.
  2. Double-click the "Bold" button.

It applies and removed the bold style properly, but an Opera native context menu is displayed.

Confirmed with Opera build 2109 at least.

Notes: it doesn't happen if the above point 1 is not done. The double-click doesn't need to be "that" fast. The second click can be under around 1s.

Change History

comment:1 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.6.1 (SVN - trunk) to 3.0

comment:2 Changed 4 years ago by hallvord@…

If there is a selection somewhere, the "Hotclick" menu triggers on doubleclick (isn't there a CKEditor issue on this problem already? ;-))

AFAIK, if you detect dblclick events and preventDefault() where suitable, the nuisance should go away. I guess we should also consider not popping up the Hotclick menu if you double-click unselectable elements (assuming that the buttons are marked unselectable - right?)

comment:3 Changed 4 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

Yes looks like a DUP of #4533

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy