Ticket #8864 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

[IE] Rich combo listbox improperly presented

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: Accessibility Version:
Keywords: IE Cc:

Description

  1. Load any sample page, focus the toolbar and navigate to the "Format" button menu;
  • Expected: AT announce the button as "menu button", with the keystroke hint prompted (press space to activate).
  • Actual: AT announce the button as "menu button", but no keystroke prompt presented, instead AT reads the title of the button link element.
  1. Press Space key to open the dropdown.
  • Expected: AT switches to form mode, announces the dropdown as "List Box";
  • Actual: No role announced, AT start with the list box item's content text, followed by the presentation to the toolbar button which is missed at the previous step.

JAWS 13 is used in the testing on IE9/Window7, Firefox works well matches the expected behavior with the same testing environment.

Attachments

8864.patch (1.2 KB) - added by garry.yao 3 years ago.
8864_2.patch (1.4 KB) - added by garry.yao 3 years ago.

Change History

comment:1 Changed 3 years ago by garry.yao

  • Milestone set to CKEditor 3.6.3

Priorities this one due to the severity, even not being a regression.

comment:2 Changed 3 years ago by garry.yao

The history pointed me to [5085], even though I dont memorize clearly what would be the rational of the change, but at least it doesn't work for now, and some best practice out there has pointed us the correct way of having it is onto the iframe's body element.

Changed 3 years ago by garry.yao

comment:3 Changed 3 years ago by garry.yao

  • Status changed from new to review
  • Owner set to garry.yao

The patch is enough to make it works in both IE and FF.

comment:4 Changed 3 years ago by fredck

  • Status changed from review to review_failed

Considering the way the panel plugin is coded, the patch can potentially break if !forceIFrame, because the <iframe> will not exist at that point. Because of this, the condition to be checked should be ( CKEDITOR.env.ie || !this.forceIFrame ).

Other than that, the patch should be ok. It makes accessibility work a bit better with IE. Let's just keep in mind that IE is not our accessibility compatibility target.

Changed 3 years ago by garry.yao

comment:5 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

comment:6 Changed 3 years ago by fredck

  • Status changed from review to review_passed

comment:7 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7451].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy