Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10044 closed Bug (duplicate)

CKEditor 4 textarea replace - Toolbar increase the textarea width

Reported by: Roy Shoa Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.1
Keywords: Cc:

Description

I have a textarea that i replace to a CKEditor 4.1 instance using the "moono" skin. The problem is that even when i configure the CKEditor instance to be 100% its toolbar increase my width depend on the its buttons amount.

From my research i understand that its happen because the in the "moono" skin "editor.css" file there is a "white-space:nowrap;" on all the element and this definition is preventing the ".cke_toolbar" object to go into a new line even if are floating.

Notes:

  • The problem exist only if the parent object is a table object and this is why it can increase its width.
  • The default CKEditor width is 100% and when its say to the editor to get the parent pbject width so in my case i do not need to set a width to the editor (or i can set 100%) and it need to get the parent width.
  • For proving that the problem is from the toolbar you can cancel the javascript note lines in the SJFiddle project and see that the editor get the correct width.
  • In my case i can not use a new line on the toolbar because the textarea width is depend on the user.

http://jsfiddle.net/royshoa/9c2Xp/2/

Change History (6)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: CKEditor 4 Toolbar removed
Resolution: duplicate
Status: newclosed

@royshoa Taking into account that this happens only in Webkit and from CKE 4.x beta then yes you are right. This looks like a duplicate of #9947

comment:2 Changed 7 years ago by Roy Shoa

Hi, Can someone open this ticket again? This is not a duplicate of #9947, It is another bug.

comment:3 Changed 7 years ago by Jakub Ś

@royshoa could you tell me why do you think that? Both test cases look the same.

comment:4 in reply to:  3 Changed 7 years ago by Roy Shoa

Replying to j.swiderski:

@royshoa could you tell me why do you think that? Both test cases look the same.

I think that it is not the same because two response:

  1. The fix that they give to it on ticket #9947 is not fixing it (Use white-space: normal for .cke_toolbar and .cke_toolgroup and destroy toolbar.)

You can see it in http://jsfiddle.net/royshoa/9c2Xp/11/ on the CSS area (use Chrome).

  1. As i see from the images that they share on ticket #9947 the toolbar is overflow but its not increasing the textarea width and in my case its increasing it with itself.

I fix this issue to my self by adding "*{white-space: normal !important;}" but i beleve that my fix can cause another bugs.

comment:5 Changed 7 years ago by Jakub Ś

@royshoa #9947 is now fixed and as you can see it fixes both issues.

I am leaving this as duplicate.

comment:6 Changed 7 years ago by Roy Shoa

Yes it fixed. Thanks a lot!!!

Last edited 7 years ago by Roy Shoa (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy