Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10058 closed Bug (wontfix)

CKEDitor 4 inline editor firefox and IE bug

Reported by: Mandeep Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: Cc:

Description

type some text and keep typing till it comes to the end of the line. Then if i select all text and change the paragraph style to 'Heading 1', the text expands and goes out of the box instead of going to the new line.

This error shows up in 18.0.1 and IE 9. Works fine in chrome.

Attachments (2)

CKEditor_inline_firefox_bug.png (40.1 KB) - added by Mandeep 6 years ago.
Attached a png describing the bug
CKEditor_inline_demo_site_firefox_bug.png (234.4 KB) - added by Mandeep 6 years ago.
The bug reproduced on your demo site

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Mandeep

Attached a png describing the bug

Changed 6 years ago by Mandeep

The bug reproduced on your demo site

comment:1 Changed 6 years ago by Mandeep

It seems that the above bug occurs only when we have a long word without a space in between. If we try to apply styles which expands the word(eg here Paragraph format 'Heading 1'), it expands. Chrome handles it correctly by breaking the word to the next line, but firefox and internet explorer doesnt.

This may appear trivial in web browsers, as one may think nobody is going to type such a long word, but when viewed from mobile, the responsive design may make the input box smaller, and thus the bug may occur with average length words also.

Hope you look into this matter. Awaiting a response.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.04.0 Beta
  1. Yes, writing such log words is very uncommon.
  2. Browsers break words by default when there is e.g. white space between them.
  3. There is CSS3 property word-wrap:brak-word http://www.w3schools.com/cssref/css3_pr_word-wrap.asp which seems to be supported in all major desktop browsers (including IE7 and IE8). I'm not sure however how mobile support for this property looks like.

Perhaps this rule could be added by editor to contenteditable element.

comment:3 Changed 6 years ago by Mandeep

So is this going to be resolved in any future versions of CKEditor or I will have to do it myself? And if yes, where exactly should I be making the change? Maybe, I wont be upgrading it very soon

comment:4 Changed 6 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

I have consulted this issue and here is what we have decided:

This is inline editing, something like plain HTML element (same rules apply) which, as explained here http://www.w3schools.com/cssref/css3_pr_word-wrap.asp, doesn't break words by default i.e. expands.

If one needs to support long words he needs to apply word wrap in page CSS. Thid is the correct solution.

comment:5 Changed 6 years ago by Mandeep

OK. Thank you for your reply :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy