Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10057 closed New Feature (wontfix)

Inline CK: Enable links in non-editable elements

Reported by: j.salak Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version:
Keywords: Cc:

Description

Is it possible to enable links inside non-editable elements of inline editable element?

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed

There are many places where links are blocked in editor. This is by design.
User could click such link by accident (e.g. when selecting text) and loosing data when getting back to correct page (This is a won’t fix issue).

I by your comment you mean that you want to edit links that are placed in contenteditable="false" element tyen this feature should be available in CKEditor 4.2 when widgets will be introduced - #9764 (This is a duplicate).

comment:2 Changed 6 years ago by j.salak

Thank you for the information. I do not want to edit link in contenteditable="false", whole that blocks are non-editable so i think it is safe to enable clicking through them. OR enable links with some key, "Ctrl" or something like that.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy