Opened 6 years ago

Closed 6 years ago

#10075 closed Bug (duplicate)

CKEditor 4 Inline editing - Toolbar appears in the wrong place when you drag the editing object

Reported by: Roy Shoa Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi The Toolbar appears in the wrong place when you drag the editing object.

Descriptive summary I am using jQuery draggable and CKEditor 4.0.1 on inline editing mode. The object that i edit with the editor is also dragable object so when the user click on it he edit it and when dragging it you can move it.

When the clicking on the object to edit it in the first time the toolbar is appear on the right place but if we dragging the object around and then click on it again to edit it sometimes the toolbar placing on the edited object instead of up to it.

Note! If i am destroying the CKEditor instance and create a new instance any time the user is starting to edit the the toolbar is all the time appear in the right place.

Its looks like the toolbar position is depended on the object position at the first time we create a CKEditor instance.

Steps to reproduce

  • Click on the object to edit it.
  • Drag the object around.
  • Click on the object to edit it again.

Sometimes the toolbar placing on the edited object instead of up to it.

Browser name and OS

  • Any browser (i am using Chrome).
  • Windows 7.

JSFiddle example: http://jsfiddle.net/royshoa/VuwJC/

Attachments (1)

123.png (11.4 KB) - added by Roy Shoa 6 years ago.
Screenshot

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by Roy Shoa

Attachment: 123.png added

Screenshot

comment:1 Changed 6 years ago by Jakub Ś

Keywords: CKEditor 4 Toolbar Draggable removed
Resolution: duplicate
Status: newclosed
Version: 4.0.1

This is a dup of #9816.

Toolbar positions horizontally correctly but not vertically.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy