Opened 7 years ago

Closed 6 years ago

#10079 closed Bug (duplicate)

IE8: Permission denied cleaning editor on focus

Reported by: Juan Pablo Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: IE Cc:

Description

I want to clean up the editor when it's focused and it's throwing an error in Internet Explorer 8 using CKEditor 4.0.1.

The code that produces the error is:

CKEDITOR.on('instanceReady', function (e) {

e.editor.on('focus', function (e) {

e.editor.setData();

});

});

CKEDITOR.replace('editor1');

Note: The error is not preventing the editor from being cleaned, but it's ugly to have an error in the status bar.

Change History (2)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 4.0.14.0 Beta

Problem can be reproduced from CKEditor 4 beta in all versions of IE.

Error:
Message: Access denied
URI: ckeditor/core/editable.js
Line: 825


It is possible that element is locked as adding setTimeout works

CKEDITOR.on('instanceReady', function (e) {
	e.editor.on('focus', function (e) {
	window.setTimeout(function(){e.editor.setData('');},10);
	//e.editor.setData('');
});
});

This can be used as workaround.

comment:2 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I'm closing this one as duplicate of #10501

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy