Opened 6 years ago

Closed 4 years ago

#10083 closed Bug (invalid)

[Android] Opening dialog windows from editor contents does not work

Reported by: Anna Tomanek Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Android Cc:

Description (last modified by Anna Tomanek)

Tested on Samsung Galaxy S, Android 4.2.1 (Jelly Bean), CKEditor 4.0.1 samples for the Standard preset, replacebycode and inline samples.

It is impossible to open editor dialog windows to edit an element that was inserted with a dialog window, like a link, anchor, table, image etc.

Double-clicking zooms the page in and out.

Clicking and holding either selects a word or opens a native browser context menu (screenshot shows the context menu for an anchor icon -- the browser recognizes it as an image and a link, hence the options).

This issue is also present in inline mode.

In Firefox 18.0.2 neither dialog windows nor context menus open.

Attachments (6)

Android-4.2.1-stock-contextmenu.png (61.8 KB) - added by Anna Tomanek 6 years ago.
Android-4.2.1-chrome-contextmenu1.png (78.8 KB) - added by Anna Tomanek 6 years ago.
Android-4.2.1-chrome-contextmenu2.png (82.9 KB) - added by Anna Tomanek 6 years ago.
Android-4.2.1-chrome-contextmenu3.png (83.6 KB) - added by Anna Tomanek 6 years ago.
Android-4.2.1-chrome-contextmenu4.png (51.3 KB) - added by Anna Tomanek 6 years ago.
Android-4.2.1-chrome-contextmenu5.png (84.9 KB) - added by Anna Tomanek 6 years ago.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by Anna Tomanek

comment:1 Changed 6 years ago by Anna Tomanek

Status: newconfirmed

comment:2 Changed 6 years ago by Anna Tomanek

Description: modified (diff)

comment:3 Changed 6 years ago by Anna Tomanek

Description: modified (diff)

comment:4 Changed 6 years ago by Anna Tomanek

In Chrome 18.0.1025469 the editor context menu can be opened by holding an object, though this does not work 100% of the time. Most of the time an item is selected first, and the virtual keyboard opens. Sometimes the menu opens but is hidden by the virtual keyboard that opens at the same time. Other times the page zooms out at the same time so the context menu is difficult to spot. It often takes a few tries to succeed.

Once the context menu shows, a dialog window like "Image Properties" can be opened.

Double-clicking zooms the page in and out.

Changed 6 years ago by Anna Tomanek

Changed 6 years ago by Anna Tomanek

Changed 6 years ago by Anna Tomanek

Changed 6 years ago by Anna Tomanek

Changed 6 years ago by Anna Tomanek

comment:5 Changed 5 years ago by Piotr Jasiun

I've tested it on Android 4.4.2 with Chrome 33 and, in fact, it is not possible to open the context menu, but I am albe to open edit dialog using toolbar button.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

We should not expect the context menu on touch screens, since such concept does not exist there. Everything should be doable with the toolbar or in other accessible (on touch screen devices) ways.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy