Opened 6 years ago

Last modified 6 years ago

#10085 confirmed Bug

Plugin divarea causes baseHref not working

Reported by: Dave Jackson Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.1
Keywords: Cc:

Description (last modified by Jakub Ś)

This worked fine in 4.0. I've only tried it with the minified ckeditor.js, so it's possible it might be a bug in that.

Please look into this as the use of baseHref is critical for my client's application.

Thanks.


Edit:
*Problem can be reporduced from CKEditor 4.0.1
*To reproduce open attached ckeditor-bug package and test 4.0.1 sample page. It turns out that when divarea is used baseHref doesn't work.
Remove the plugin and it works again:

 $(document).ready(function() {
        $('#make-editor').click(function(){
            CKEDITOR.replace('testeditor', {
		removePlugins : 'divarea'
		});
        });
});

Please see comment:3 for detailed TC

Attachments (2)

ckeditor.js (454.4 KB) - added by Dave Jackson 6 years ago.
ckeditor file that does not pick up and use baseHref.
ckeditor-bug.tgz (1.8 MB) - added by Dave Jackson 6 years ago.
Standalone test-case demonstrating bug

Change History (15)

Changed 6 years ago by Dave Jackson

Attachment: ckeditor.js added

ckeditor file that does not pick up and use baseHref.

comment:1 Changed 6 years ago by Dave Jackson

Version: 4.0.1

comment:2 Changed 6 years ago by Jakub Ś

Status: newpending
Version: 4.0.1

I have set in config.js

config.baseHref = 'http://192.168.1.112:9593/';

then I have used relative path in image dialog (/test_image.png) and it worked without problems. The same thing happened with initial data loaded into editor.

Could you double check and if you still get this error could you specify exact TC steps to reproduce this problem in fresh (without nay customizations) CKEditor?

Changed 6 years ago by Dave Jackson

Attachment: ckeditor-bug.tgz added

Standalone test-case demonstrating bug

comment:3 Changed 6 years ago by Dave Jackson

Hi,

I have just attached a standalone test case. Here are steps to reproduce the problem with the tarball I sent you:

  1. unzip the file.
  2. In a browser, navigate to ckeditortest-4.0.html
  3. Click the Make button - that should convert the textarea into an editor
  4. Click the image icon in the editor - an image popup will appear
  5. Enter (without the quotes) "nakedeye.jpg" into the url field and hit tab.
  6. You should now see the image previewed. (It uses baseHref setting in the html to actually point to image/test/path/nakedeye.jpg)
  7. Now, navigate to ckeditortest-4.0.1.html and repeat steps 3-6. In this case, it shows a broken image.
  8. The only difference between these two tests is the version of the ckeditor library.

Thanks, -Dave J.

comment:4 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Hi,

Please note that set of plugins in 4.0.1 is very different to what you have in 4.0.

I have tried your sample with default CKEditor 4.0.1.1 (and 4.0.1) full version and image did show up.

My guess is that either one of these custom plugins or some custom change of yours is causing this as provided TC works with default version.

I'm closing this ticket as invalid. If you are able to provide TC that breaks default version - please provide it and I will reopen this ticket.

comment:5 Changed 6 years ago by Dave Jackson

The plugins included are ones your website has provided. I didn't add these from arbitrary places.

I'd be happy to remove all of the plugins and keep adding them back one at a time until I can identify which one causes the problem, but then isn't that still a bug on your part, since you are providing the plugins?

comment:6 Changed 6 years ago by Jakub Ś

since you are providing the plugins?

That is not quite true. There are not only plugins provided by CKSource but also third-party plugins provided by users.

I'm not sure if you have made any customizations to editor code. If yes, this doesn't have to be plugin fault but one of your changes.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:7 Changed 6 years ago by Dave Jackson

I made zero customizations to editor code. I just used your builder to pull some plugins that you provide on your site and things broke.

I think you guys have a responsibility to test for interoperability of third party plugins with your own code if you're going to distribute them with your code.

It's pretty unprofessional to put this on your users. At the very least, you should have a really big flashing warning letting your users know that you *don't* do any interoperability testing and it's therefore at our own risk to use any plugins that aren't shipped by you.

I rebuilt an install from just your Full version plus 4 plugins and things seem to work now. Still, I'm disappointed in your lack of responsibility for what you distribute to your users.

comment:8 Changed 6 years ago by Jakub Ś

@dave@... in case you haven't noticed it, before building you can visit every plugin website (directly from builder) and check its author and other information like compatibility. You will probably say "I don't have time for this" but if programmer is creating software and just takes 'whatever' that is unprofessional.

comment:9 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: closedreopened

comment:10 Changed 6 years ago by Jakub Ś

Status: reopenedconfirmed

@dave@ it seems that I need to apologise.
To make sure, I have checked your list of plugins for editor 4.0.1 and it seems that one of our plugins - divarea is causing this (without it works fine):

 $(document).ready(function() {
        $('#make-editor').click(function(){
            CKEDITOR.replace('testeditor', {
		removePlugins : 'divarea'
		});
        });
});

comment:11 Changed 6 years ago by Jakub Ś

Description: modified (diff)
Summary: baseHref does not work in ckeditor-4.0.1Plugin divarea causes baseHref not working
Version: 4.0.1

comment:12 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:13 Changed 6 years ago by Jakub Ś

Description: modified (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy