Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10128 closed Bug (invalid)

config.toolbarLocation = 'bottom' not working in inline editing mode

Reported by: cgoudey Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: Cc:

Description

Download ckeditor, add this line in config.js:

config.toolbarLocation = 'bottom';

=> toolbar not showing in inlineall and inlinebycode samples

Change for

config.toolbarLocation = 'top';

=> it works

Change History (4)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.0.14.0 Beta

Problem can be reporduced from CKEditor 4 beta in all browsers.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

Inline editor has only one space - top. The bottom one is not available. IMO everything works as expected. I'm closing this issue, but if you have different opinion we can reopen it.

Note: CKEditor 4.1 will reintroduce shared spaces - the feature allowing to place top or bottom space in your own container. Feature is already available for testin (see #9387) and will be released soon.

comment:3 Changed 6 years ago by Jakub Ś

When you use config.toolbarLocation = 'bottom'; you get only styled contentarea without toolbar. It looks like broken editor.
If toolbar is allowed in one space only - then perhaps such setting should be ignored for inline editor and display toolbar at the top no matter what?

comment:4 Changed 6 years ago by cgoudey

Then the documentation needs to be updated to point out this fact. Now for toolbarLocation config option it says : "The "UI space" to which rendering the toolbar. For the default editor implementation, the recommended options are 'top' and 'bottom'."

And the documentation of Inline Editing too doesn't mention the fact that 'bottom' is not valid.

Now for the bottom location, this is important in some cases. For example I have a table which each cell contains an inline editable div. When editing the cells of the first row, the editor shows up on top of the table headers cells. If it could show up below, no problem anymore.

I'm not sure how to achieve the same thing than with toolbarLocation='bottom' when editing the table cells in my example, ie an editor which shows up below the cell, above the cell of next row. It may be possible but surely is harder than the toolbarLocation setting.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy