Opened 6 years ago

Closed 6 years ago

#10129 closed Bug (invalid)

Unable to link an image in a Definition List using IE9.

Reported by: SP Dev Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: Cc:

Description

Hi,

When adding a hyperlink to an image in a definition list, HTML is incorrect in IE. I am using CKEditor 3.6.4 for ASP.NET.

Steps to reproduce:

1) Copy/paste the following:

<dl class="image block1" id="CEInsert2219">

<dt jquery15102809381276178383="29">

<img alt="photo.JPG" src="/data/files/gallery/ContentGallery/thumb/tn-photo2.JPG" /></dt>

</dl>

2) Then using the editor, select the image and make it a hyperlink.

Using IE, you'll see html code is incorrect and looks like to:

<dl class="image block1" id="CEInsert2219">

<dt jquery15102809381276178383="29">

<img alt="photo.JPG" src="/data/files/gallery/ContentGallery/thumb/tn-photo2.JPG" /><a href="http://google.com">http://google.com</a></dt>

</dl>

instead of

<dl class="image block1" id="CEInsert2219">

<dt jquery15102809381276178383="29">

<a href="http://google.com"><img alt="photo.JPG" src="/data/files/gallery/ContentGallery/thumb/tn-photo2.JPG" /> </a></dt>

</dl>

I have attached a screenshot to this case. Let me know, Best, Toni

Attachments (1)

ckeditor-bug.png (28.3 KB) - added by SP Dev 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by SP Dev

Attachment: ckeditor-bug.png added

comment:1 Changed 6 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed

I have tried your scenario in CKEditor asp.net 3.6.4 with ckeditor client-side updated to 4.0.1.1 ad problem didn't occur there.

The best solution here is simply downloading CKEditor 4.0.1.1, unpacking it to ckeditor folder and exchanging old cke_aspnet_364\_Samples\ckeditor folder to new one.

comment:2 Changed 6 years ago by Jakub Ś

Resolution: wontfix
Status: closedreopened

comment:3 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy