Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10130 closed Bug (invalid)

Can't stop fckeditor modify my html code when switch from Source mode.

Reported by: sam Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

With latest code of ckeditor, when I copied a html template from quicksqles editor (which is also another ckeditor) or ebay html editor in to the Source area of the latest version of the ckeditor, and then switch out of Source mode, the html code gets modified. How can I stop that?

The configuration of the config.js file does not take any effect. Thus I considered this is a BUG.

Here is the config.js code:

CKEDITOR.editorConfig = function( config ) {

config.htmlEncodeOutput = false;

config.entities = false;

config.entities_greek = false; config.entities_latin = false; config.removePlugins = 'elementspath,enterkey,entities,forms,pastefromword,htmldataprocessor,specialchar' ;

config.toolbar = 'Custom';

config.toolbar_Custom = [

{ name: 'document', items : [ 'Source','-','NewPage','Preview' ] }, { name: 'clipboard', items : [ 'Cut','Copy','Paste','PasteText','PasteFromWord','-','Undo','Redo' ] }, { name: 'editing', items : [ 'Find','Replace','-','SelectAll','-','SpellChecker','Scayt' ] }, { name: 'insert', items : [ 'Image','Table','HorizontalRule','Smiley','SpecialChar','PageBreak'

,'Iframe' ] },

'/',

{ name: 'styles', items : [ 'Styles','Format','Font','FontSize' ] }, { name: 'basicstyles', items : [ 'Bold','Italic','Strike','-','RemoveFormat' ] }, { name: 'paragraph', items : [ 'NumberedList','BulletedList','-','Outdent','Indent','-','Blockquote' ] }, { name: 'links', items : [ 'Link','Unlink','Anchor' ] }, { name: 'colors', items : [ 'TextColor','BGColor' ] }, { name: 'tools', items : [ 'Maximize' ] }

];

Best regards Sam

Change History (3)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

This is core functionality of editor and can't be turned off. In fact every editor works that way.

Editor works with clean HTML. If user enters invalid (e.g. p inside span) HTML editor has to correct it according to specification. If this didn't happen editor would become very unstable application with many unpredicted styling errors which we can't allow.

comment:2 Changed 6 years ago by sam

this core funcitonality is wrong. I don't meant there shouldn't be an auto fix function, the problem is it never functioned properly. While other html editors also perform auto correction, but they didn't mess up the correct html tags. You got to believe this function is faulty and better be humbled yourself and make a big coding review'''

comment:3 Changed 6 years ago by Jakub Ś

This functionality is working as expected IMHO.

Could you perhaps send us part of HTML that gets broken? Please tell us what you paste into editor and what you get.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy