Opened 7 years ago

Closed 7 years ago

#10137 closed Bug (fixed)

Empty Syles combo in filter sample

Reported by: Olek Nowodziński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.1 RC
Component: Core : Styles Version: 4.0.2
Keywords: Cc:

Description

  1. http://ckeditor4.t/ckeditor/samples/filter.html
  2. See Styles combos of editor 2 & 3: they're empty.
  3. This looks like:

http://i.imgur.com/TpsnkJw.jpg

Change History (7)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

To reproduce:

  1. Get the latest major version
  2. Reload cache in browser and load filter sample.
  3. Styles dropdowns for 2nd and 3rd editor are empty.

comment:2 Changed 7 years ago by Piotrek Koszuliński

Not a bug - feature. Combo is empty, because all styles available for current selection are disallowed by ACF. Select image and you'll see image's styles there.

But the issue still exists. To avoid confusion like yours we may add more rules for these editors.

comment:3 Changed 7 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:4 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

Created branch t/10137:

  • Created custom stylesSet for this sample so no stylescombos are empty.
  • Removed unnecessary "editor 5" that was for testing purposes only and didn't reflect any filtering feature.

comment:5 Changed 7 years ago by Piotrek Koszuliński

Owner: changed from Olek Nowodziński to Piotrek Koszuliński

We don't need to set special styles set for filter sample. Default one is ok. Less changes make sample less confusing.

I pushed t/10137b which:

  • adds ACRs for 2nd and 3rd editors which enable some of the default styles,
  • removes editor5 which indeed is unnecessary - next one (based on h1 editable) is much better.

comment:6 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:7 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on major with git:516399f.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy