Opened 7 years ago

Closed 5 years ago

#10157 closed Bug (fixed)

Copy/Paste issues in Chrome with Div based editor

Reported by: p3r3 Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version: 4.0 Beta
Keywords: Webkit Cc:

Description

Copy and paste does not work in Chrome.

I had a more detailed ticket that got rejected by akismet so I will make this short.

http://ckeditor.com/demo#div, clear all content so its blank, try copying in blocks of text only input (like lorem ipsum). The area does not get updated but when you hit source you can see the content was pasted sans formatting in some cases. Also it seems like you cant get a cursor in the editable area after pasting as well. This issue only appears in chrome.

Change History (7)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newpending

I couldn't reproduce this issue, however, I'm not sure if I understood it.

Could you try to post more detailed TC one more time? If Akismet will block it, please mail it to me - p.koszulinski at cksource.com

PS. Which version of Chrome do you have?

comment:2 Changed 7 years ago by Jakub Ś

Keywords: paste div demo removed
Version: 4.0.1

I have the same as Reinmar :)

@p3r3 if possible, please provide detailed step by step scenario and if you get problems sending your test case, please send it directly to @Reinmar

comment:3 Changed 7 years ago by p3r3

Sorry about that try copying text from here:

Steps: 1.) Copy text from lorem ipsum generator. 2.) Go to http://ckeditor.com/demo#div. 3.) Select all and delete current demo text. 4.) Paste contents from lorem ipsum

Expected Result: -Text appears in contentarea

Actual Result: -Nothing appears, when you click source you will see the text

comment:4 Changed 7 years ago by p3r3

Akismet is blocking the site url i use to generate lorem ipsum.

Try this one: http://www.ipsum-generator.com/loremipsum/paragraphs

It is important that content is from a textarea and not an html page.

comment:5 Changed 7 years ago by Jakub Ś

Keywords: Webkit added
Status: pendingconfirmed
Version: 4.0 Beta

I was able to reproduce this problem from CKEditor 4 beta in Webkit browsers. This is happening in both inline and divarea editors.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Status: confirmedpending

I'm not able to reproduce this any more. @j.swiderski - could you check it?

comment:7 Changed 5 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

I have checked Safari 5 and Safari 8 and could not reproduce this problem so I guess we can close it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy